码迷,mamicode.com
首页 > 其他好文 > 详细

田忌赛马

时间:2014-11-08 12:06:48      阅读:214      评论:0      收藏:0      [点我收藏+]

标签:style   http   io   color   ar   os   sp   for   数据   

题目来自:NYOJ

田忌赛马

时间限制:3000 ms  |  内存限制:65535 KB
难度:3
描述
Here is a famous story in Chinese history.

"That was about 2300 years ago. General Tian Ji was a high official in the country Qi. He likes to play horse racing with the king and others."

"Both of Tian and the king have three horses in different classes, namely, regular, plus, and super. The rule is to have three rounds in a match; each of the horses must be used in one round. The winner of a single round takes two hundred silver dollars from the loser."

"Being the most powerful man in the country, the king has so nice horses that in each class his horse is better than Tian‘s. As a result, each time the king takes six hundred silver dollars from Tian."

"Tian Ji was not happy about that, until he met Sun Bin, one of the most famous generals in Chinese history. Using a little trick due to Sun, Tian Ji brought home two hundred silver dollars and such a grace in the next match."

"It was a rather simple trick. Using his regular class horse race against the super class from the king, they will certainly lose that round. But then his plus beat the king‘s regular, and his super beat the king‘s plus. What a simple trick. And how do you think of Tian Ji, the high ranked official in China?"

Were Tian Ji lives in nowadays, he will certainly laugh at himself. Even more, were he sitting in the ACM contest right now, he may discover that the horse racing problem can be simply viewed as finding the maximum matching in a bipartite graph. Draw Tian‘s horses on one side, and the king‘s horses on the other. Whenever one of Tian‘s horses can beat one from the king, we draw an edge between them, meaning we wish to establish this pair. Then, the problem of winning as many rounds as possible is just to find the maximum matching in this graph. If there are ties, the problem becomes more complicated, he needs to assign weights 0, 1, or -1 to all the possible edges, and find a maximum weighted perfect matching...

However, the horse racing problem is a very special case of bipartite matching. The graph is decided by the speed of the horses --- a vertex of higher speed always beat a vertex of lower speed. In this case, the weighted bipartite matching algorithm is a too advanced tool to deal with the problem.

In this problem, you are asked to write a program to solve this special case of matching problem.
输入
The input consists of many test cases. Each case starts with a positive integer n (n <= 1000) on the first line, which is the number of horses on each side. The next n integers on the second line are the speeds of Tian’s horses. Then the next n integers on the third line are the speeds of the king’s horses.
输出
For each input case, output a line containing a single number, which is the maximum money Tian Ji will get, in silver dollars.

样例输入
3
92 83 71
95 87 74
2
20 20
20 20
2
20 19
22 18
样例输出
200
0
0

题目大意:有多组测试数据,对于每组测试数据第一行输入一个数字n,表示有n匹马参与比赛,接下来输入两行数据,第一行为田忌每匹马的速度,第二行为齐王每匹马的速度,输出一行表示田忌赢的钱数(赢一次的200,输一场也是200)

#include<stdio.h>
#include<stdlib.h>

int tian[1005],king[1005];
//从大到小排序
int com(const void *a,const void *b)
{
	return (*(int *)b - *(int *)a);
}
//读入每匹马的速度
void read(int n)
{
	int i;
	for(i=0;i<n;i++){
		scanf("%d",&tian[i]);
	}
	for(i=0;i<n;i++){
		scanf("%d",&king[i]);
	}
}
//求的赢的钱数
int match(int n)
{
	qsort(tian,n,sizeof(tian[0]),com);
	qsort(king,n,sizeof(king[0]),com);
	int tl,tf,kl,kf,win,lose;
	tl = kl = n-1;
	tf = kf = 0;
	win = lose = 0;
	while(tf<=tl)//遍历
	{
		if(tian[tf]>king[kf]){//若田忌最快的马比齐王最快的马快,win一场
			win ++;tf ++; kf ++;
		}
		else if(tian[tl] > king[kl]){//若田忌最慢的马比齐王最慢的马快,win一场
			win ++;tl--;kl--;
		}
		else 
		{
			if(tian[tl]<king[kf])//若田忌最慢的马比齐王最快的马慢,lose一场
				lose ++;
			tl--;kf++;
		}
	}
	return (win-lose)*200;
}
int main()
{
	int n;
	while(scanf("%d",&n)!=EOF)
	{
		read(n);
		printf("%d\n",match(n));
	}
	return 0;
}


田忌赛马

标签:style   http   io   color   ar   os   sp   for   数据   

原文地址:http://blog.csdn.net/u012437355/article/details/40918543

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!