码迷,mamicode.com
首页 > 其他好文 > 详细

hdu 1080 Human Gene Functions (动态规划)

时间:2014-11-08 16:47:19      阅读:95      评论:0      收藏:0      [点我收藏+]

标签:des   style   blog   http   io   color   ar   os   java   

Human Gene Functions

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 2402    Accepted Submission(s): 1360


Problem Description
It is well known that a human gene can be considered as a sequence, consisting of four nucleotides, which are simply denoted by four letters, A, C, G, and T. Biologists have been interested in identifying human genes and determining their functions, because these can be used to diagnose human diseases and to design new drugs for them. 

A human gene can be identified through a series of time-consuming biological experiments, often with the help of computer programs. Once a sequence of a gene is obtained, the next job is to determine its function. One of the methods for biologists to use in determining the function of a new gene sequence that they have just identified is to search a database with the new gene as a query. The database to be searched stores many gene sequences and their functions – many researchers have been submitting their genes and functions to the database and the database is freely accessible through the Internet. 

A database search will return a list of gene sequences from the database that are similar to the query gene. Biologists assume that sequence similarity often implies functional similarity. So, the function of the new gene might be one of the functions that the genes from the list have. To exactly determine which one is the right one another series of biological experiments will be needed. 

Your job is to make a program that compares two genes and determines their similarity as explained below. Your program may be used as a part of the database search if you can provide an efficient one. 

Given two genes AGTGATG and GTTAG, how similar are they? One of the methods to measure the similarity of two genes is called alignment. In an alignment, spaces are inserted, if necessary, in appropriate positions of the genes to make them equally long and score the resulting genes according to a scoring matrix. 

For example, one space is inserted into AGTGATG to result in AGTGAT-G, and three spaces are inserted into GTTAG to result in –GT--TAG. A space is denoted by a minus sign (-). The two genes are now of equal length. These two strings are aligned: 

AGTGAT-G 
-GT--TAG 

In this alignment, there are four matches, namely, G in the second position, T in the third, T in the sixth, and G in the eighth. Each pair of aligned characters is assigned a score according to the following scoring matrix.
bubuko.com,布布扣

* denotes that a space-space match is not allowed. The score of the alignment above is (-3)+5+5+(-2)+(-3)+5+(-3)+5=9. 

Of course, many other alignments are possible. One is shown below (a different number of spaces are inserted into different positions): 

AGTGATG 
-GTTA-G 

This alignment gives a score of (-3)+5+5+(-2)+5+(-1) +5=14. So, this one is better than the previous one. As a matter of fact, this one is optimal since no other alignment can have a higher score. So, it is said that the similarity of the two genes is 14.
 

Input
The input consists of T test cases. The number of test cases ) (T is given in the first line of the input. Each test case consists of two lines: each line contains an integer, the length of a gene, followed by a gene sequence. The length of each gene sequence is at least one and does not exceed 100. 
 

Output
The output should print the similarity of each test case, one per line. 
 

Sample Input
2 7 AGTGATG 5 GTTAG 7 AGCTATT 9 AGCTTTAAA
 

Sample Output
14 21
 

求两个串匹配的最大权值,dp[i][j]表示分别为i,j的两个串的进行匹配的最大值。

每个字符可以选择和空格匹配或者和非空格匹配,

dp[i][j]=max(dp[i-1][j-1]+v[i][j],dp[i-1][j]+v[i][kong],dp[i][j-1]+v[kong][j]);

v[i][j]表示字符i和j匹配的权值.

#include<stdio.h>
#include<string.h>
#include<stdlib.h>
#define LL __int64
const int inf=0x1f1f1f1f;
#define N 110    
int a[5][5]={{5,-1,-2,-1,-3},{-1,5,-3,-2,-4},{-2,-3,5,-2,-2},
{-1,-2,-2,5,-1},{-3,-4,-2,-1,-inf}};  //把字符编号映射为二维数组
char s1[N],s2[N];
int dp[N][N];
int change(char c)  //找到每个字符对应的编号
{
    if(c=='A') return 0;
    else if(c=='C') return 1;
    else if(c=='G') return 2;
    else if(c=='T') return 3;
}
int mmax(int a,int b,int c) 
{
    int t=a>b?a:b;
    t=t>c?t:c;
    return t;
}
int main()
{
    int tt,n,m,i,j;
    scanf("%d",&tt);
    while(tt--)
    {
        scanf("%d %s",&n,s1);
        scanf("%d %s",&m,s2);
        int k=4;       //空格编号
        memset(dp,0,sizeof(dp));
        for(i=1;i<=n;i++)    //一个dp[i][0]长度为i的字符串和空串匹配的最大值
            dp[i][0]=dp[i-1][0]+a[change(s1[i-1])][k];
        for(i=1;i<=m;i++)  
            dp[0][i]=dp[0][i-1]+a[change(s2[i-1])][k];
        for(i=1;i<=n;i++)  
        {
            int u=change(s1[i-1]);
            for(j=1;j<=m;j++)
            {
                int v=change(s2[j-1]);
                dp[i][j]=mmax(dp[i-1][j-1]+a[u][v],dp[i-1][j]+a[u][k],dp[i][j-1]+a[k][v]);
                //printf("%d ",dp[i][j]);
            }
           // puts("");
        }
        printf("%d\n",dp[n][m]);
    }
    return 0;
}












hdu 1080 Human Gene Functions (动态规划)

标签:des   style   blog   http   io   color   ar   os   java   

原文地址:http://blog.csdn.net/u011721440/article/details/40921691

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!