标签:des style blog io color ar os java sp
Max Sum Plus Plus
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 17336 Accepted Submission(s): 5701
Problem Description
Now I think you have got an AC in Ignatius.L‘s "Max Sum" problem. To be a brave ACMer, we always challenge ourselves to more difficult problems. Now you are faced with a more difficult problem.
Given a consecutive number sequence S1, S2, S3, S4 ... Sx, ... Sn (1 ≤ x ≤ n ≤ 1,000,000, -32768 ≤ Sx ≤ 32767). We define
a function sum(i, j) = Si + ... + Sj (1 ≤ i ≤ j ≤ n).
Now given an integer m (m > 0), your task is to find m pairs of i and j which make sum(i1, j1) + sum(i2, j2) + sum(i3, j3) + ... + sum(im,
jm) maximal (ix ≤ iy ≤ jx or ix ≤ jy ≤ jx is not allowed).
But I`m lazy, I don‘t want to write a special-judge module, so you don‘t have to output m pairs of i and j, just output the maximal summation of sum(ix, jx)(1 ≤ x ≤ m) instead. ^_^
Input
Each test case will begin with two integers m and n, followed by n integers S1, S2, S3 ... Sn.
Process to the end of file.
Output
Output the maximal summation described above in one line.
Sample Input
1 3 1 2 3
2 6 -1 4 -2 3 -2 3
Sample Output
6
8
Hint
Huge input, scanf and dynamic programming is recommended.
给定一个数组,求M段连续的子段和最大。dp[i][j]表示前i段选择第j个元素的最优解。
dp[i][j]=max(dp[i][j-1]+a[j] , max( dp[i-1][k] ) + a[j] ) 0<k<j
因为k<j,所以我们可以用两个一维数组,一个dp[i]记录当前行状态,一个d[i]记录下一行可选的最大值;
#include<stdio.h>
#include<string.h>
#include<stdlib.h>
#include<algorithm>
using namespace std;
#define LL __int64
const int inf=0x1f1f1f1f;
#define N 1000010
int a[N];
LL d[N],dp[N];
int main()
{
int i,j,n,m;
while(~scanf("%d%d",&m,&n))
{
for(i=1;i<=n;i++)
{
scanf("%d",&a[i]);
dp[i]=0;
d[i]=0;
}
d[0]=dp[0]=0;
for(i=1;i<=m;i++)
{
LL tmp=-inf;
for(j=i;j<=n;j++)
{
dp[j]=max(dp[j-1]+a[j],d[j-1]+a[j]);
d[j-1]=tmp; //记录下一行第j列可选的第i-1个区间的值
tmp=max(tmp,dp[j]);
}
}
LL ans=-inf;
for(i=m;i<=n;i++)
ans=max(ans,dp[i]);
printf("%I64d\n",ans);
}
return 0;
}
hdu 1024 Max Sum Plus Plus (子段和最大问题)
标签:des style blog io color ar os java sp
原文地址:http://blog.csdn.net/u011721440/article/details/40922839