码迷,mamicode.com
首页 > 其他好文 > 详细

572 - Oil Deposits

时间:2014-11-08 18:21:48      阅读:176      评论:0      收藏:0      [点我收藏+]

标签:acm   uva   编程   

The GeoSurvComp geologic survey company is responsible for detecting underground oil deposits. GeoSurvComp works with one large rectangular region of land at a time, and creates a grid that divides the land into numerous square plots. It then analyzes each plot separately, using sensing equipment to determine whether or not the plot contains oil.

A plot containing oil is called a pocket. If two pockets are adjacent, then they are part of the same oil deposit. Oil deposits can be quite large and may contain numerous pockets. Your job is to determine how many different oil deposits are contained in a grid.

Input 

The input file contains one or more grids. Each grid begins with a line containing m and n, the number of rows and columns in the grid, separated by a single space. If m = 0 it signals the end of the input; otherwise bubuko.com,布布扣 and bubuko.com,布布扣. Following this are m lines of n characters each (not counting the end-of-line characters). Each character corresponds to one plot, and is either `*‘, representing the absence of oil, or `@‘, representing an oil pocket.

Output 

For each grid, output the number of distinct oil deposits. Two different pockets are part of the same oil deposit if they are adjacent horizontally, vertically, or diagonally. An oil deposit will not contain more than 100 pockets.

Sample Input 

1 1
*
3 5
*@*@*
**@**
*@*@*
1 8
@@****@*
5 5
****@
*@@*@
*@**@
@@@*@
@@**@
0 0

Sample Output 

0
1
2
2
#include <stdio.h>
#include <string.h>

char graph[110][110];
int visit[110][110];

void findOil(int i,int j)
{
	if(visit[i][j] || graph[i][j]=='*')
		return;
	visit[i][j]=1;
	findOil(i-1,j-1);
	findOil(i-1,j);
	findOil(i-1,j+1);
	findOil(i,j-1);
	findOil(i,j+1);
	findOil(i+1,j-1);
	findOil(i+1,j);
	findOil(i+1,j+1);
}

int main()
{
	int m,n,count;
	while(scanf("%d%d",&m,&n)==2 && m!=0)
	{
		count=0;
		memset(graph,'*',sizeof(graph));
		memset(visit,0,sizeof(visit));
		getchar();
		for(int i=1;i<=m;i++)
		{
			for(int j=1;j<=n;j++)
			{
				graph[i][j]=getchar();
			}
			getchar();
		}
		for(int i=1;i<=m;i++)
			for(int j=1;j<=n;j++)
			{
				if(!visit[i][j] && graph[i][j]!='*')
				{
					count++;
					findOil(i,j);
				}
			}
			printf("%d\n",count);
	}
	return 0;
}



572 - Oil Deposits

标签:acm   uva   编程   

原文地址:http://blog.csdn.net/xj_347/article/details/40922213

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!