码迷,mamicode.com
首页 > 其他好文 > 详细

Uva 11584 - Partitioning by Palindromes dp

时间:2014-11-09 18:08:19      阅读:140      评论:0      收藏:0      [点我收藏+]

标签:uva 11584   dp   

Problem H: Partitioning by Palindromes

bubuko.com,布布扣

We say a sequence of characters is a palindrome if it is the same written forwards and backwards. For example, ‘racecar‘ is a palindrome, but ‘fastcar‘ is not.

partition of a sequence of characters is a list of one or more disjoint non-empty groups of consecutive characters whose concatenation yields the initial sequence. For example, (‘race‘, ‘car‘) is a partition of ‘racecar‘ into two groups.

Given a sequence of characters, we can always create a partition of these characters such that each group in the partition is a palindrome! Given this observation it is natural to ask: what is the minimum number of groups needed for a given string such that every group is a palindrome?

For example:

  • ‘racecar‘ is already a palindrome, therefore it can be partitioned into one group.
  • ‘fastcar‘ does not contain any non-trivial palindromes, so it must be partitioned as (‘f‘, ‘a‘, ‘s‘, ‘t‘, ‘c‘, ‘a‘, ‘r‘).
  • ‘aaadbccb‘ can be partitioned as (‘aaa‘, ‘d‘, ‘bccb‘).

Input begins with the number n of test cases. Each test case consists of a single line of between 1 and 1000 lowercase letters, with no whitespace within.

For each test case, output a line containing the minimum number of groups required to partition the input into groups of palindromes.

Sample Input

3
racecar
fastcar
aaadbccb

Sample Output

1
7
3

Kevin Waugh


初学dp先从简单题开始~~~~~

题意:给出长度不超过1000的字符串,把它分割成若干个回文字串,求能分成的最少字串数。

代码:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
#include <string>
#include <map>
#include <stack>
#include <vector>
#include <set>
#include <queue>
#pragma comment (linker,"/STACK:102400000,102400000")
#define maxn 1005
#define MAXN 2005
#define mod 1000000009
#define INF 0x3f3f3f3f
#define pi acos(-1.0)
#define eps 1e-6
#define lson rt<<1,l,mid
#define rson rt<<1|1,mid+1,r
typedef long long ll;
using namespace std;

int dp[maxn];
char str[maxn];

bool ISok(int s,int e)
{
    for (int i=s;i<=s+(e-s+1)/2;i++)
        if (str[i]!=str[e+s-i])
            return false;
    return true;
}

int main()
{
    int n;
    scanf("%d",&n);
    while (n--)
    {
        memset(dp,0,sizeof(dp));
        scanf("%s",str+1);
        int len=strlen(str+1);
        for (int i=1;i<=len;i++)
        {
            dp[i]=i;
            for (int j=1;j<=i;j++)
            {
                if (ISok(j,i))
                    dp[i]=min(dp[i],dp[j-1]+1);
            }
        }
        printf("%d\n",dp[len]);
    }
    return 0;
}
/*
3
racecar
fastcar
aaadbccb
*/



Uva 11584 - Partitioning by Palindromes dp

标签:uva 11584   dp   

原文地址:http://blog.csdn.net/u014422052/article/details/40951095

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!