码迷,mamicode.com
首页 > 其他好文 > 详细

棋盘问题

时间:2020-06-21 13:34:53      阅读:38      评论:0      收藏:0      [点我收藏+]

标签:==   res   空格   pair   air   要求   情况   越界   end   

棋盘问题 原题链接

在一个给定形状的棋盘(形状可能是不规则的)上面摆放棋子,棋子没有区别。要求摆放时任意的两个棋子不能放在棋盘中的同一行或者同一列,请编程求解对于给定形状和大小的棋盘,摆放k个棋子的所有可行的摆放方案C。

Input

输入含有多组测试数据。
每组数据的第一行是两个正整数,n k,用一个空格隔开,表示了将在一个n*n的矩阵内描述棋盘,以及摆放棋子的数目。 n <= 8 , k <= n
当为-1 -1时表示输入结束。
随后的n行描述了棋盘的形状:每行有n个字符,其中 # 表示棋盘区域, . 表示空白区域(数据保证不出现多余的空白行或者空白列)。

Output

对于每一组数据,给出一行输出,输出摆放的方案数目C (数据保证C<2^31)。

Sample Input

技术图片

Sample Output

技术图片

题解

在棋盘中的每一个可以放得位置,有两种情况放或者不放,直接枚举这两种情况即可(做搜索的时候要注意搜索顺序)

代码如下

#include <iostream>
#include <algorithm>
#include <cmath>
#include <cstring>
#include <string>
#include <vector>
#include <stack>
#include <map>
#include <queue>
#include <sstream>
#include <set>
#include <cctype>
#define mem(a,b) memset(a,b,sizeof(a))

using namespace std;

typedef pair<int, int> PII;
const int N = 10;
char g[N][N];
int n, m;
bool row[N], col[N];//row是用来标记行,col用来标记列

int dfs(int x, int y, int s){
    if(s == m) return 1;
    if(y == n) y = 0, x ++;//列越界
    if(x == n) return 0;//行越界,直接返回
    

    int res = dfs(x, y + 1, s);//不放棋子的情况
    if(!row[x] && !col[y] && g[x][y] != ‘.‘){
        row[x] = col[y] = true;
        res += dfs(x, y + 1, s + 1);//放棋子的情况
        row[x] = col[y] = false;
    }

    return res;
}

int main(){
    
    while(cin >> n >> m){
        if(n == -1 && m == -1) break;
        for(int i = 0; i < n; ++i)
            for(int j = 0; j < n; ++j)
                cin >> g[i][j];

        cout << dfs(0 , 0, 0) << endl;
    }

    return 0;
}

棋盘问题

标签:==   res   空格   pair   air   要求   情况   越界   end   

原文地址:https://www.cnblogs.com/Lngstart/p/13172065.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!