码迷,mamicode.com
首页 > 其他好文 > 详细

HDOJ 2769 Disgruntled Judge 扩展GCD

时间:2014-11-09 23:47:22      阅读:341      评论:0      收藏:0      [点我收藏+]

标签:des   style   blog   http   io   color   ar   os   java   


扩展GCD:

枚举a,扩展GCD求b,再暴力检查

Disgruntled Judge

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 329    Accepted Submission(s): 142


Problem Description
Once upon a time, there was an nwerc judge with a tendency to create slightly too hard problems. As a result, his problems were never solved. As you can image, this made our judge somewhat frustrated. This year, this frustration has culminated, and he has decided that rather than spending a lot of time constructing a well-crafted problem, he will simply write some insanely hard problem statement and just generate some random input and output files. After all, why bother having proper test data if nobody is going to try the problem anyway?

Thus, the judge generates a testcase by simply letting the input be a random number, and letting the output be another random number. Formally, to generate the data set with T test cases, the judge generates 2T random numbers x1, ..., x2T between 0 and 10000, and then writes T, followed by the sequence x1, x3, x5, ..., x2T-1 to the input file, and the sequence x2, x4, x6, ..., x2T to the output file.

The random number generator the judge uses is quite simple. He picks three numbers x1, a, and b between 0 and 10000 (inclusive), and then for i from 2 to 2T lets xi = (a · xi-1 + b) mod 10001.

You may have thought that such a poorly designed problem would not be used in a contest of such high standards as nwerc. Well, you were wrong.
 

Input
On the first line one positive number: the number of testcases, at most 100. After that per testcase:

* One line containing an integer n (0 ≤ n ≤ 10000): an input testcase. 

The input file is guaranteed to be generated by the process described above.
 

Output
Per testcase:

* One line with an integer giving the answer for the testcase. 

If there is more than one output file consistent with the input file, any one of these is acceptable.
 

Sample Input
3 17 822 3014
 

Sample Output
9727 1918 4110
 

Source
 



#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>

using namespace std;

typedef long long int LL;
const int mod=10001;

LL s[mod+100],n;

void ex_gcd(LL a,LL b,LL& d,LL& x,LL& y)
{
    if(!b)
    {
        d=a;x=1;y=0;
    }
    else
    {
        ex_gcd(b,a%b,d,y,x);
        y-=a/b*x;
    }
}

int main()
{
    while(cin>>n)
    {
        n*=2;
        for(int i=1;i<=n;i+=2) cin>>s[i];
        for(int a=0;a<=10000;a++)
        {
            LL b,k,d;
            LL t=s[3]-a*a*s[1];
            ex_gcd(a+1,-mod,d,b,k);
            if(t%d) continue;
            b=b*t/d;
            bool flag=true;
            for(int i=2;i<=n;i++)
            {
                LL temp=(s[i-1]*a+b)%mod;
                if(i%2==1)
                {
                    if(temp!=s[i])
                    {
                        flag=false; break;
                    }
                }
                else s[i]=temp;
            }
            if(flag==true)
            {
                for(int i=2;i<=n;i+=2)
                {
                    cout<<s[i]<<endl;
                }
                break;
            }
        }
    }
    return 0;
}



HDOJ 2769 Disgruntled Judge 扩展GCD

标签:des   style   blog   http   io   color   ar   os   java   

原文地址:http://blog.csdn.net/ck_boss/article/details/40959985

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!