码迷,mamicode.com
首页 > 其他好文 > 详细

DAY 4

时间:2020-06-26 18:29:06      阅读:50      评论:0      收藏:0      [点我收藏+]

标签:mat   路径   ber   logs   ISE   output   john   ble   sep   

DAY4

T1:Watching Fireworks is Fun

T2:The Prices

链接:https://www.cnblogs.com/hellohhy/p/13195760.html

T3:Perform巡回演出

T4:动物园

T5:Disease Manangement 疾病管理

题目描述

Alas! \(A\) set of \(D (1 <= D <= 15)\) diseases (numbered \(1..D\)) is running through the farm. Farmer John would like to milk as many of his N \((1 <= N <= 1,000)\) cows as possible. If the milked cows carry more than K \((1 <= K <= D)\) different diseases among them, then the milk will be too contaminated and will have to be discarded in its entirety. Please help determine the largest number of cows FJ can milk without having to discard the milk.

输入格式

  • Line 1: Three space-separated integers: \(N, D, and K\)
  • Lines 2..N+1: Line \(i+1\) describes the diseases of cow \(i\) with a list of 1 or more space-separated integers. The first integer, \(d_i\) , is the count of cow \(i"s\) diseases; the next \(d_i\) integers enumerate the actual diseases. Of course, the list is empty if \(d_i\) is 0.
    有N头牛,它们可能患有D种病,现在从这些牛中选出若干头来,但选出来的牛患病的集合中不过超过K种病.

输出格式

Line 1: M, the maximum number of cows which can be milked.

样例

样例输入

6 3 2
0---------第一头牛患0种病
1 1------第二头牛患一种病,为第一种病.
1 2
1 3
2 2 1
2 2 1

样例输出

5

OUTPUT DETAILS

If FJ milks cows 1, 2, 3, 5, and 6, then the milk will have only two diseases (#1 and #2), which is no greater than K (2).

题解

emmm,状压dp。

code

#include<cstdio>
#include<cstring>
#include<algorithm>
#define ll long long
using namespace std;
const int lqs=1200;
int lim[lqs];
int f[1<<16];
int find(int x){
	int cnt=0;
	while(x){
		x-=x&(-x);
		cnt++;
	}
	return cnt;
}
int main(){
	int n,m,k;
	scanf("%d%d%d",&n,&m,&k);
	for(int i=1;i<=n;i++){
		int t;
		scanf("%d",&t);
		while(t--){
			int a;
			scanf("%d",&a);
			lim[i]|=1<<a-1;
		}
	}
	int Mx=1<<m,ans=0;
	for(int i=1;i<=n;i++)
		for(int s=Mx-1;s;s--){	
			f[s|lim[i]]=max(f[s|lim[i]],f[s]+1);
			if(find(s|lim[i])<=k)ans=max(ans,f[s|lim[i]]);
			//printf("%d %d\n",s|lim[i],f[s|lim[i]]);
		}
	printf("%d\n",ans);
}

Redundant Paths 分离的路径

Mining Your Own Business

DAY 4

标签:mat   路径   ber   logs   ISE   output   john   ble   sep   

原文地址:https://www.cnblogs.com/hellohhy/p/13195710.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!