标签:des style http io color ar os java sp
Chessboard
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 271 Accepted Submission(s): 144
Problem Description
Consider the problem of tiling an n×n chessboard by polyomino pieces that are k×1 in size; Every one of the k pieces of each polyomino tile must align exactly with one of the chessboard squares. Your task is to figure out the maximum number of chessboard squares
tiled.
Input
There are multiple test cases in the input file.
First line contain the number of cases T (T≤10000).
In the next T lines contain T cases , Each case has two integers n and k. (1≤n,k≤100)
Output
Print the maximum number of chessboard squares tiled.
Sample Input
Sample Output
Source
详细题解链接:http://www.brand.site.co.il/riddles/201403a.html
AC代码:
#include<iostream>
#include<cstdio>
using namespace std;
int main(){
int T; scanf("%d",&T);
while(T--){
int n,k;
scanf("%d%d",&n,&k);
if(n<k){
printf("0\n");
continue;
}
int r=n%k;
if(r<=k/2){
int ans=n*n-r*r;
printf("%d\n",ans);
}
else{
int ans=n*n-(k-r)*(k-r);
printf("%d\n",ans);
}
}
return 0;
}
hdu 5100
标签:des style http io color ar os java sp
原文地址:http://blog.csdn.net/my_acm/article/details/40953077