码迷,mamicode.com
首页 > 其他好文 > 详细

HDU 4788 Hard Disk Drive(数学)

时间:2014-11-10 19:54:56      阅读:187      评论:0      收藏:0      [点我收藏+]

标签:hdu   数学   成都   

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=4788



Problem Description
  Yesterday your dear cousin Coach Pang gave you a new 100MB hard disk drive (HDD) as a gift because you will get married next year.
  But you turned on your computer and the operating system (OS) told you the HDD is about 95MB. The 5MB of space is missing. It is known that the HDD manufacturers have a different capacity measurement. The manufacturers think 1 “kilo” is 1000 but the OS thinks that is 1024. There are several descriptions of the size of an HDD. They are byte, kilobyte, megabyte, gigabyte, terabyte, petabyte, exabyte, zetabyte and yottabyte. Each one equals a “kilo” of the previous one. For example 1 gigabyte is 1 “kilo” megabytes.
  Now you know the size of a hard disk represented by manufacturers and you want to calculate the percentage of the “missing part”.
 
Input
  The first line contains an integer T, which indicates the number of test cases.
  For each test case, there is one line contains a string in format “number[unit]” where number is a positive integer within [1, 1000] and unit is the description of size which could be “B”, “KB”, “MB”, “GB”, “TB”, “PB”, “EB”, “ZB”, “YB” in short respectively.
 
Output
  For each test case, output one line “Case #x: y”, where x is the case number (starting from 1) and y is the percentage of the “missing part”. The answer should be rounded to two digits after the decimal point.
 
Sample Input
2 100[MB] 1[B]
 
Sample Output
Case #1: 4.63% Case #2: 0.00%
Hint
bubuko.com,布布扣
 
Source


PS:

求一个单位相差分别是1000和1024的差值!

见案例!

代码如下:

#include <cstdio>
#include <cstring>
int findd(char s[])
{
    int len = strlen(s);
    if(len <= 3)
        return 0;
    if(s[1] == 'K')
        return 1;
    if(s[1] == 'M')
        return 2;
    if(s[1] == 'G')
        return 3;
    if(s[1] == 'T')
        return 4;
    if(s[1] == 'P')
        return 5;
    if(s[1] == 'E')
        return 6;
    if(s[1] == 'Z')
        return 7;
    if(s[1] == 'Y')
        return 8;
}
int main()
{
    int t;
    int num;
    char s[7];
    int cas = 0;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d%s",&num,s);
        int k = findd(s);
        if( k == 0)
        {
            printf("Case #%d: 0.00%%\n",++cas);
            continue;
        }
        double t1 = 1.0, t2 = 1;
        for(int i = 0; i < k; i++)
        {
            t1*=(1000.0/1024.0);
        }
//        printf("%.2lf\n",t1);
        printf("Case #%d: %.2lf%%\n",++cas,(1-(t1/t2))*100.0);
    }
    return 0;
}


HDU 4788 Hard Disk Drive(数学)

标签:hdu   数学   成都   

原文地址:http://blog.csdn.net/u012860063/article/details/40985369

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!