码迷,mamicode.com
首页 > 其他好文 > 详细

并查集+贪心 HDU4424

时间:2014-11-10 23:29:43      阅读:340      评论:0      收藏:0      [点我收藏+]

标签:并查集   贪心   

先对边进行从大到小的排序

并查集保存节点数和长度

Conquer a New Region

Time Limit: 8000/4000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1289    Accepted Submission(s): 429


Problem Description
The wheel of the history rolling forward, our king conquered a new region in a distant continent.
There are N towns (numbered from 1 to N) in this region connected by several roads. It‘s confirmed that there is exact one route between any two towns. Traffic is important while controlled colonies are far away from the local country. We define the capacity C(i, j) of a road indicating it is allowed to transport at most C(i, j) goods between town i and town j if there is a road between them. And for a route between i and j, we define a value S(i, j) indicating the maximum traffic capacity between i and j which is equal to the minimum capacity of the roads on the route.
Our king wants to select a center town to restore his war-resources in which the total traffic capacities from the center to the other N - 1 towns is maximized. Now, you, the best programmer in the kingdom, should help our king to select this center.
 

Input
There are multiple test cases.
The first line of each case contains an integer N. (1 <= N <= 200,000)
The next N - 1 lines each contains three integers a, b, c indicating there is a road between town a and town b whose capacity is c. (1 <= a, b <= N, 1 <= c <= 100,000)
 

Output
For each test case, output an integer indicating the total traffic capacity of the chosen center town.
 

Sample Input
4 1 2 2 2 4 1 2 3 1 4 1 2 1 2 4 1 2 3 1
 

Sample Output
4 3
 

Source
 
#include <stdio.h>
#include <stdlib.h>
#include <malloc.h>
#include <limits.h>
#include <ctype.h>
#include <string.h>
#include <string>
#include <algorithm>
#include <iostream>
#include <queue>
#include <stack>
#include <deque>
#include <vector>
#include <set>
#include <map>
using namespace std;
#define MAXN 200000 + 200
typedef __int64 LL;

struct node{
    LL x;
    LL y;
    LL cost;
}E[MAXN];

LL f[MAXN];//父亲节点
LL dis[MAXN];//与该节点相连所有的点到该节点的权值的和
LL sum[MAXN];//该节点的儿子数

bool cmp(node a,node b){
    return a.cost > b.cost;
}

LL find(LL x){
    if(x == f[x]){
        return x;
    }
    return f[x] = find(f[x]);
}

void init(){
    LL i;
    for(i=0;i<MAXN;i++){
        f[i] = i;
        dis[i] = 0;
        sum[i] = 1;
    }
}

void unio(LL x,LL y,LL v){
    f[x] = y;
    sum[y]+=sum[x];
    dis[y] = v;
}

int main(){
    LL n,i;

    while(~scanf("%I64d",&n)){
        for(i=1;i<n;i++){
            scanf("%I64d%I64d%I64d",&E[i].x,&E[i].y,&E[i].cost);
        }
        sort(E+1,E+n,cmp);
        init();
        for(i=1;i<n;i++){
            LL dx = find(E[i].x);
            LL dy = find(E[i].y);
            LL dis1 = dis[dx]+E[i].cost*sum[dy];//因为E【i】.cost一定要比这两个集合中的任何一条边都要短
            LL dis2 = dis[dy]+E[i].cost*sum[dx];
            if(dis1 > dis2){
                unio(dy,dx,dis1);
            }
            else{
                unio(dx,dy,dis2);
            }
        }
        printf("%I64d\n",dis[find(1)]);
    }

    return 0;
}


并查集+贪心 HDU4424

标签:并查集   贪心   

原文地址:http://blog.csdn.net/zcr_7/article/details/40985565

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!