码迷,mamicode.com
首页 > 其他好文 > 详细

Poj 3254 Corn Fields(状态压缩)

时间:2014-11-10 23:30:04      阅读:397      评论:0      收藏:0      [点我收藏+]

标签:poj 3254   corn fields   dp   状态压缩   

Corn Fields
Time Limit: 2000MS   Memory Limit: 65536K
Total Submissions: 8291   Accepted: 4409

Description

Farmer John has purchased a lush new rectangular pasture composed of M by N (1 ≤ M ≤ 12; 1 ≤ N ≤ 12) square parcels. He wants to grow some yummy corn for the cows on a number of squares. Regrettably, some of the squares are infertile and can‘t be planted. Canny FJ knows that the cows dislike eating close to each other, so when choosing which squares to plant, he avoids choosing squares that are adjacent; no two chosen squares share an edge. He has not yet made the final choice as to which squares to plant.

Being a very open-minded man, Farmer John wants to consider all possible options for how to choose the squares for planting. He is so open-minded that he considers choosing no squares as a valid option! Please help Farmer John determine the number of ways he can choose the squares to plant.

Input

Line 1: Two space-separated integers: M and N 
Lines 2..M+1: Line i+1 describes row i of the pasture with N space-separated integers indicating whether a square is fertile (1 for fertile, 0 for infertile)

Output

Line 1: One integer: the number of ways that FJ can choose the squares modulo 100,000,000.

Sample Input

2 3
1 1 1
0 1 0

Sample Output

9

Hint

Number the squares as follows:
1 2 3
  4  

There are four ways to plant only on one squares (1, 2, 3, or 4), three ways to plant on two squares (13, 14, or 34), 1 way to plant on three squares (134), and one way to plant on no squares. 4+3+1+1=9.

Source



题意:
一个n*m的矩阵,每个格子是0或者1,1表示土壤肥沃可以种植草地,0则不可以。在种草地的格子可以放牛,但边相邻的两个格子不允许同时放牛,问总共有多少种放牛的方法?(不放牛也算一种情况)

题解:
#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<string>
#include<algorithm>
#include<cstdlib>
#include<set>
#include<queue>
#include<stack>
#include<vector>
#include<map>

#define N 100010
#define Mod 100000000
#define lson l,mid,idx<<1
#define rson mid+1,r,idx<<1|1
#define lc idx<<1
#define rc idx<<1|1
const double EPS = 1e-11;
const double PI = acos ( -1.0 );
const double E = 2.718281828;
typedef long long ll;

const int INF = 1000010;

using namespace std;

int a[14], dp[14][1 << 12 + 1];
int cnt[1010];
int n, m;
int len;

bool ok ( int x )///判断同行是否有相邻的
{
    if ( x & ( x << 1 ) || ( x & ( x >> 1 ) ) ) return false;
    return true;
}

void build()
{
    len = 0;
    for ( int i = 0; i < ( 1 << m ); i++ )
    {
        if ( ok ( i ) )
        {
            cnt[len++] = i;
        }
    }
}


int main()
{
    while ( cin >> n >> m )
    {
        memset ( a, 0, sizeof a );
        int x;
        for ( int i = 0; i < n; i++ )
            for ( int j = 0; j < m; j++ )
            {
                cin >> x;
                if ( !x )
                    a[i] |= ( 1 << j );
            }
        memset ( dp, 0, sizeof dp );
        build();
        for ( int i = 0; i < len; i++ )
            if ( ! ( cnt[i]&a[0] ) )
                dp[0][i] = 1;
        for ( int i = 1; i < n; i++ )
        {
            for ( int j = 0; j < len; j++ )
            {
                if ( a[i] & cnt[j] )
                    continue;
                for ( int k = 0; k < len; k++ )
                {
                    if ( cnt[k]&cnt[j] || ( cnt[k]&a[i - 1] ) )
                        continue;
                    dp[i][j] += dp[i - 1][k];
                    dp[i][j] %= Mod;
                }
            }
        }
        int ans = 0;
        for ( int i = 0; i < len; i++ )
        {
            ans += dp[n - 1][i];
            ans %= Mod;
        }
        cout << ans << endl;
    }
    return 0;
}


Poj 3254 Corn Fields(状态压缩)

标签:poj 3254   corn fields   dp   状态压缩   

原文地址:http://blog.csdn.net/acm_baihuzi/article/details/40985441

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!