码迷,mamicode.com
首页 > 其他好文 > 详细

hdu 4283You Are the One

时间:2020-07-18 00:42:55      阅读:89      评论:0      收藏:0      [点我收藏+]

标签:--   single   stage   contains   summary   std   ppi   clu   his   

The TV shows such as You Are the One has been very popular. In order to meet the need of boys who are still single, TJUT hold the show itself. The show is hold in the Small hall, so it attract a lot of boys and girls. Now there are n boys enrolling in. At the beginning, the n boys stand in a row and go to the stage one by one. However, the director suddenly knows that very boy has a value of diaosi D, if the boy is k-th one go to the stage, the unhappiness of him will be (k-1)*D, because he has to wait for (k-1) people. Luckily, there is a dark room in the Small hall, so the director can put the boy into the dark room temporarily and let the boys behind his go to stage before him. For the dark room is very narrow, the boy who first get into dark room has to leave last. The director wants to change the order of boys by the dark room, so the summary of unhappiness will be least. Can you help him?

Input  The first line contains a single integer T, the number of test cases.  For each case, the first line is n (0 < n <= 100)
  The next n line are n integer D1-Dn means the value of diaosi of boys (0 <= Di <= 100)
Output  For each test case, output the least summary of unhappiness .
Sample Input

2
  
5
1
2
3
4
5

5
5
4
3
2
2

Sample Output

Case #1: 20
Case #2: 24

代码
#include<iostream>
#include<algorithm>
#include<cstring>
using namespace std;

const int INF = 0x3f3f3f;
int n, num[105], dp[105][105], sum[105];

int main()
{
    int t, cnt;
    cin >> t;
    while (t--)
    {
        scanf("%d", &n);
        memset(dp, 0, sizeof dp);

        for (int i = 1; i <= n; i++)
        {
            scanf("%d", &num[i]);
        }
        sum[0] = 0;
        for (int i = 1; i <= n; i++)
        {
            sum[i] = sum[i - 1] + num[i];
        }
        for (int i = 1; i <= n; i++)
        {
            for (int j = i + 1; j <= n; j++)
                dp[i][j] = INF;
        }
        for (int i = n; i >= 1; i--)
        {
            for (int j = i + 1; j <= n; j++)
            {
                for (int k = 1; k <= j - i + 1; k++)
                {
                    dp[i][j] = min(dp[i][j], dp[i + 1][i + k - 1] + num[i] * (k - 1) + dp[i + k][j] + k*(sum[j] - sum[i + k - 1]));
                }
            }
        }
        printf("Case #%d: %d\n", cnt++, dp[1][n]);
    }
    system("pause");
    return 0;
}

 

hdu 4283You Are the One

标签:--   single   stage   contains   summary   std   ppi   clu   his   

原文地址:https://www.cnblogs.com/pcdl/p/13333755.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!