标签:poj3050
Hopscotch
Time Limit: 1000MS |
|
Memory Limit: 65536K |
Total Submissions: 2113 |
|
Accepted: 1514 |
Description
The cows play the child‘s game of hopscotch in a non-traditional way. Instead of a linear set of numbered boxes into which to hop, the cows create a 5x5 rectilinear grid of digits parallel to the x and y axes.
They then adroitly hop onto any digit in the grid and hop forward, backward, right, or left (never diagonally) to another digit in the grid. They hop again (same rules) to a digit (potentially a digit already visited).
With a total of five intra-grid hops, their hops create a six-digit integer (which might have leading zeroes like 000201).
Determine the count of the number of distinct integers that can be created in this manner.
Input
* Lines 1..5: The grid, five integers per line
Output
* Line 1: The number of distinct integers that can be constructed
Sample Input
1 1 1 1 1
1 1 1 1 1
1 1 1 1 1
1 1 1 2 1
1 1 1 1 1
Sample Output
15
Hint
OUTPUT DETAILS:
111111, 111112, 111121, 111211, 111212, 112111, 112121, 121111, 121112, 121211, 121212, 211111, 211121, 212111, and 212121 can be constructed. No other values are possible.
Source
暴搜,水题..
#include <stdio.h>
#include <string.h>
#include <map>
int G[5][5], ans;
const int mov[][2] = {0, 1, 0, -1, 1, 0, -1, 0};
std::map<int, int> mp;
void DFS(int x, int y, int k, int sum) {
if(k == 6) {
if(mp[sum]++ == 0) ++ans;
return;
}
for(int i = 0, a, b; i < 4; ++i) {
a = x+mov[i][0];
b = y+mov[i][1];
if(a>=0&&b>=0&&a<5&&b<5)
DFS(a, b, k+1, sum*10+G[x][y]);
}
}
int main() {
int i, j;
for(i = 0; i < 5; ++i)
for(j = 0; j < 5; ++j)
scanf("%d", &G[i][j]);
for(i = 0; i < 5; ++i)
for(j = 0; j < 5; ++j)
DFS(i, j, 0, 0);
printf("%d\n", ans);
return 0;
}
POJ3050 Hopscotch 【DFS】
标签:poj3050
原文地址:http://blog.csdn.net/chang_mu/article/details/40987619