码迷,mamicode.com
首页 > 其他好文 > 详细

POJ2393 Yogurt factory 【贪心】

时间:2014-11-11 08:13:10      阅读:121      评论:0      收藏:0      [点我收藏+]

标签:poj2393

Yogurt factory
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 6821   Accepted: 3488

Description

The cows have purchased a yogurt factory that makes world-famous Yucky Yogurt. Over the next N (1 <= N <= 10,000) weeks, the price of milk and labor will fluctuate weekly such that it will cost the company C_i (1 <= C_i <= 5,000) cents to produce one unit of yogurt in week i. Yucky‘s factory, being well-designed, can produce arbitrarily many units of yogurt each week. 

Yucky Yogurt owns a warehouse that can store unused yogurt at a constant fee of S (1 <= S <= 100) cents per unit of yogurt per week. Fortuitously, yogurt does not spoil. Yucky Yogurt‘s warehouse is enormous, so it can hold arbitrarily many units of yogurt. 

Yucky wants to find a way to make weekly deliveries of Y_i (0 <= Y_i <= 10,000) units of yogurt to its clientele (Y_i is the delivery quantity in week i). Help Yucky minimize its costs over the entire N-week period. Yogurt produced in week i, as well as any yogurt already in storage, can be used to meet Yucky‘s demand for that week.

Input

* Line 1: Two space-separated integers, N and S. 

* Lines 2..N+1: Line i+1 contains two space-separated integers: C_i and Y_i.

Output

* Line 1: Line 1 contains a single integer: the minimum total cost to satisfy the yogurt schedule. Note that the total might be too large for a 32-bit integer.

Sample Input

4 5
88 200
89 400
97 300
91 500

Sample Output

126900

Hint

OUTPUT DETAILS: 
In week 1, produce 200 units of yogurt and deliver all of it. In week 2, produce 700 units: deliver 400 units while storing 300 units. In week 3, deliver the 300 units that were stored. In week 4, produce and deliver 500 units. 

Source

每次更新相邻的下一周即可。因为若下一周被更新,那么下一周可以用来更新剩下的周,所以当前周只需要负责下一周。

#include <stdio.h>
#include <string.h>

#define maxn 10002

int min(int a, int b) {
    return a < b ? a : b;
}

int X[maxn], Y[maxn];

int main() {
    int N, S, i, j;
    __int64 sum;
    while(scanf("%d%d", &N, &S) == 2) {
        for(i = 0; i < N; ++i)
            scanf("%d%d", &X[i], &Y[i]);
        for(i = sum = 0; i < N; ++i) {
            sum += X[i] * Y[i];
            if(i != N - 1)
                X[i+1] = min(X[i+1], X[i] + S);
        }
        printf("%I64d\n", sum);
    }
    return 0;
}


POJ2393 Yogurt factory 【贪心】

标签:poj2393

原文地址:http://blog.csdn.net/chang_mu/article/details/40986427

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!