码迷,mamicode.com
首页 > 其他好文 > 详细

1125 Chain the Ropes (25分)

时间:2020-07-18 22:21:25      阅读:73      评论:0      收藏:0      [点我收藏+]

标签:loop   scripts   com   nts   specific   nta   ensure   can   div   

Given some segments of rope, you are supposed to chain them into one rope. Each time you may only fold two segments into loops and chain them into one piece, as shown by the figure. The resulting chain will be treated as another segment of rope and can be folded again. After each chaining, the lengths of the original two segments will be halved.

技术图片

Your job is to make the longest possible rope out of N given segments.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (2N10?4??). Then N positive integer lengths of the segments are given in the next line, separated by spaces. All the integers are no more than 10?4??.

Output Specification:

For each case, print in a line the length of the longest possible rope that can be made by the given segments. The result must be rounded to the nearest integer that is no greater than the maximum length.

Sample Input:

8
10 15 12 3 4 13 1 15
 

Sample Output:

14

思路:贪心,因为越先加进去的被减半的次数会越多,所以让长的绳子尽可能不被对半,先加入短的绳子。


#include<bits/stdc++.h>
using namespace std;
vector<int> ve;
int main(){
    int n;
    cin>>n;
    ve.resize(n);
    for(int i=0; i<n; ++i) cin>>ve[i];
    sort(ve.begin(), ve.end());
    double sum=ve[0];
    for(int i=1; i<n; ++i) sum = (sum+ve[i])/2;
    cout<<floor(sum)<<endl;
    return 0;
}

 

1125 Chain the Ropes (25分)

标签:loop   scripts   com   nts   specific   nta   ensure   can   div   

原文地址:https://www.cnblogs.com/LS-Joze/p/13337398.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!