码迷,mamicode.com
首页 > 其他好文 > 详细

2Ants(独立,一个个判,弹性碰撞,想象)

时间:2020-07-21 01:11:57      阅读:78      评论:0      收藏:0      [点我收藏+]

标签:horizon   stream   就会   tar   ace   define   cas   data   需要   

Ants
Description
An army of ants walk on a horizontal pole of length l cm, each with a constant speed of 1 cm/s. When a walking ant reaches an end of the pole, it immediatelly falls off it. When two ants meet they turn back and start walking in opposite directions. We know the original positions of ants on the pole, unfortunately, we do not know the directions in which the ants are walking. Your task is to compute the earliest and the latest possible times needed for all ants to fall off the pole.


Input
The first line of input contains one integer giving the number of cases that follow. The data for each case start with two integer numbers: the length of the pole (in cm) and n, the number of ants residing on the pole. These two numbers are followed by n integers giving the position of each ant on the pole as the distance measured from the left end of the pole, in no particular order. All input integers are not bigger than 1000000 and they are separated by whitespace.


Output
For each case of input, output two numbers separated by a single space. The first number is the earliest possible time when all ants fall off the pole (if the directions of their walks are chosen appropriately) and the second number is the latest possible such time.


Sample Input

2
10 3
2 6 7
214 7
11 12 7 13 176 23 191


Sample Output

4 8
38 207


题意:在一根长为L的水平木棍上有一群数量为n的蚂蚁,它们以每秒1cm/s的速度走到木棍一端就会掉下去。现在知道它们的起始位置是距离木根左端点的x处。但是不知道它们爬行的方向。在相向而行的两只蚂蚁相遇后,它们会掉头往反方向走。问所有蚂蚁都落下木棍的最快时间和最慢时间。
题解:因为当不相遇的时候,每只蚂蚁是相互独立的;而当相遇的时候,两只蚂蚁反向,也可以等价于每只蚂蚁是相互独立的,所以只需要分别判每个蚂蚁即可,因为是同时进行,所以不用加和,而是求出可以选的最大的那个。

ac代码:
#include<iostream>
#include<algorithm>
#include<string>
#define maxn 1000100
int a[maxn];
using namespace std;

int main()
{
    int len,n,timemax=0,timemin=0;
    cin>>len>>n;
    for(int i=0;i<n;i++)
        cin>>a[i];
    for(int i=0;i<n;i++)
    {
        if(a[i]>len-a[i])
        {
            timemax=max(timemax,a[i]);
            timemin=max(len-a[i],timemin);
        }
        else
        {
            timemin=max(timemin,a[i]);
            timemax=max(len-a[i],timemax);
        }
    }
    cout<<"min="<<timemin<<endl;
    cout<<"max="<<timemax<<endl;
    return 0;
}

2Ants(独立,一个个判,弹性碰撞,想象)

标签:horizon   stream   就会   tar   ace   define   cas   data   需要   

原文地址:https://www.cnblogs.com/Joe2019/p/13347834.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!