码迷,mamicode.com
首页 > 其他好文 > 详细

hdoj 2522 A simple problem 【模拟】

时间:2014-11-11 19:13:46      阅读:180      评论:0      收藏:0      [点我收藏+]

标签:模拟

A simple problem

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 3199    Accepted Submission(s): 1164


Problem Description
Zty很痴迷数学问题.。一天,yifenfei出了个数学题想难倒他,让他回答1 / n。但Zty却回答不了^_^. 请大家编程帮助他.
 

Input
第一行整数T,表示测试组数。后面T行,每行一个整数 n (1<=|n|<=10^5).
 

Output
输出1/n. (是循环小数的,只输出第一个循环节).
 

Sample Input
4 2 3 7 168
 

Sample Output
0.5 0.3 0.142857 0.005952380
 

代码:

#include <stdio.h>
#include <string.h>
#define M 100005

bool vis[M];

int main(){
    int n, t;
    scanf("%d", &t);
    while(t --){
        scanf("%d", &n);
        memset(vis, false, sizeof(vis));
        if(n == 1||n == -1){
            printf("%d\n", n); continue;
        }
        if(n < 0){
            printf("-"); n = -n;
        }
        int pre = 1, mod = 1;
        printf("0.");
        while(1){
            pre*=10;
            if(vis[mod]||mod == 0) break;  
            vis[mod] = 1;
            mod = pre%n;
            printf("%d", pre/n);
            pre %= n;
        }
        printf("\n");
    }
    return 0;
}


hdoj 2522 A simple problem 【模拟】

标签:模拟

原文地址:http://blog.csdn.net/shengweisong/article/details/41014141

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!