标签:dfs 模拟
题目来源:http://poj.org/problem?id=1111
Image Perimeters
Time Limit: 1000MS |
|
Memory Limit: 10000K |
Total Submissions: 7896 |
|
Accepted: 4711 |
Description
Technicians in a pathology lab analyze digitized images of slides. Objects on a slide are selected for analysis by a mouse click on the object. The perimeter of the boundary of an object is one useful measure. Your task is to determine this perimeter for selected
objects.
The digitized slides will be represented by a rectangular grid of periods, ‘.‘, indicating empty space, and the capital letter ‘X‘, indicating part of an object. Simple examples are
XX Grid 1 .XXX Grid 2
XX .XXX
.XXX
...X
..X.
X...
An X in a grid square indicates that the entire grid square, including its boundaries, lies in some object. The X in the center of the grid below is adjacent to the X in any of the 8 positions around it. The grid squares for any two adjacent X‘s overlap on
an edge or corner, so they are connected.
XXX
XXX Central X and adjacent X‘s
XXX
An object consists of the grid squares of all X‘s that can be linked to one another through a sequence of adjacent X‘s. In Grid 1, the whole grid is filled by one object. In Grid 2 there are two objects. One object contains only the lower left grid square.
The remaining X‘s belong to the other object.
The technician will always click on an X, selecting the object containing that X. The coordinates of the click are recorded. Rows and columns are numbered starting from 1 in the upper left hand corner. The technician could select the object in Grid 1 by clicking
on row 2 and column 2. The larger object in Grid 2 could be selected by clicking on row 2, column 3. The click could not be on row 4, column 3.
One useful statistic is the perimeter of the object. Assume each X corresponds to a square one unit on each side. Hence the object in Grid 1 has perimeter 8 (2 on each of four sides). The perimeter for the larger object in Grid 2 is illustrated in the figure
at the left. The length is 18.
Objects will not contain any totally enclosed holes, so the leftmost grid patterns shown below could NOT appear. The variations on the right could appear:
Impossible Possible
XXXX XXXX XXXX XXXX
X..X XXXX X... X...
XX.X XXXX XX.X XX.X
XXXX XXXX XXXX XX.X
..... ..... ..... .....
..X.. ..X.. ..X.. ..X..
.X.X. .XXX. .X... .....
..X.. ..X.. ..X.. ..X..
..... ..... ..... .....
Input
The input will contain one or more grids. Each grid is preceded by a line containing the number of rows and columns in the grid and the row and column of the mouse click. All numbers are in the range 1-20. The rows of the grid follow, starting on the next line,
consisting of ‘.‘ and ‘X‘ characters.
The end of the input is indicated by a line containing four zeros. The numbers on any one line are separated by blanks. The grid rows contain no blanks.
Output
For each grid in the input, the output contains a single line with the perimeter of the specified object.
Sample Input
2 2 2 2
XX
XX
6 4 2 3
.XXX
.XXX
.XXX
...X
..X.
X...
5 6 1 3
.XXXX.
X....X
..XX.X
.X...X
..XXX.
7 7 2 6
XXXXXXX
XX...XX
X..X..X
X..X...
X..X..X
X.....X
XXXXXXX
7 7 4 4
XXXXXXX
XX...XX
X..X..X
X..X...
X..X..X
X.....X
XXXXXXX
0 0 0 0
Sample Output
8
18
40
48
8
Source
题意:
按题目给定的规则确定一个区域,求该区域的周长。
题意:
模拟+DFS 首先用DFS跑一边确定区域,然后计算周长。单独一个X的周长为4,~~ 此题可以先将各个X当做独立的求出周长,然后再减去相邻"X"重叠的部分。
PS:光棍节,特意把1111翻出来A了~~
AC代码:
#include<iostream>
#include<cstring>
using namespace std;
string map[25];
int chess[25][25],visit[25][25],cx,cy,dx,dy,count,sum;
int dir[8][2]={
{1,0},{0,1},{-1,0},{0,-1},
{-1,-1},{1,1},{1,-1},{-1,1}
};
bool dfs(int x,int y)
{
if(map[x][y]=='.') return false;
bool flag=false;
if(!visit[x][y]){
chess[x][y]=1;
visit[x][y]=1;
for(int i=0;i<8;i++){
int dx=dir[i][0]+x,dy=dir[i][1]+y;
if(dx>=0&&dy>=0&&dx<cx&&dy<cy&&map[dx][dy]=='X'){
chess[dx][dy]=1;
flag=true;
dfs(dx,dy);
}
}
}
return flag;
}
void calc(){
for(int i=0;i<cx;i++)
for(int j=0;j<cy;j++)
{
if(chess[i][j]){
sum++;
for(int k=0;k<4;k++){
int dx=i+dir[k][0],dy=j+dir[k][1];
if(dx>=0&&dy>=0&&dx<cx&&dy<cy&&chess[dx][dy])
count++;
}
}
}
}
int main()
{
while(cin>>cx>>cy>>dx>>dy&&cx)
{
sum=count=0;
dx--;dy--;
memset(chess,0,sizeof(chess));
memset(visit,0,sizeof(visit));
for(int i=0;i<cx;i++)
cin>>map[i];
if(map[dx][dy]=='.'){
cout<<0<<endl; continue;
}
dfs(dx,dy);
calc();
cout<<sum*4-count<<endl;
}
return 0;
}
POJ 1111 Image Perimeters
标签:dfs 模拟
原文地址:http://blog.csdn.net/mummyding/article/details/41013735