码迷,mamicode.com
首页 > 其他好文 > 详细

对称排列

时间:2014-11-11 19:19:41      阅读:210      评论:0      收藏:0      [点我收藏+]

标签:des   style   io   color   ar   os   sp   for   数据   

描述
In your job at Albatross Circus Management (yes, it‘s run by a bunch of clowns), you have just finished writing a program whose output is a list of names in nondescending order by length (so that each name is at least as long as the one preceding it). However, your boss does not like the way the output looks, and instead wants the output to appear more symmetric, with the shorter strings at the top and bottom and the longer strings in the middle. His rule is that each pair of names belongs on opposite ends of the list, and the first name in the pair is always in the top part of the list. In the first example set below, Bo and Pat are the first pair, Jean and Kevin the second pair, etc. 
输入
The input consists of one or more sets of strings, followed by a final line containing only the value 0. Each set starts with a line containing an integer, n, which is the number of strings in the set, followed by n strings, one per line, NOT SORTED. None of the strings contain spaces. There is at least one and no more than 15 strings per set. Each string is at most 25 characters long. 
输出
For each input set print "SET n" on a line, where n starts at 1, followed by the output set as shown in the sample output.
If length of two strings is equal,arrange them as the original order.(HINT: StableSort recommanded)
样例输入
7
Bo
Pat
Jean
Kevin
Claude
William
Marybeth
6
Jim
Ben
Zoe
Joey
Frederick
Annabelle
5
John
Bill
Fran
Stan
Cece
0
样例输出
SET 1
Bo
Jean
Claude
Marybeth
William
Kevin
Pat
SET 2
Jim
Zoe
Frederick
Annabelle
Joey
Ben
SET 3
John
Fran
Cece
Stan

Bill

解题思路:

  本题应当先将字符串排序,排完序后,先将奇数位置的字符串逐字输出,而偶数位置的字符串倒序输出。

本题用结构体存储数据,结构体中有每个字符串的长度,然后根据长度将字符串排序。

字符串的输出只需要用循环控制即可。

程序代码:

#include<stdio.h>
#include<string.h>
struct str{
	char a[30];
	int len;
}st[20];
void fun(int n)
{
	int i,j;
	struct str t;
	for(i=1;i<n;i++){
		for(j=1;j<=n-i;j++)
		{
			if(st[j].len>st[j+1].len)
			{
				t=st[j];
				st[j]=st[j+1];
				st[j+1]=t;
			}
		}
	}
	//for(i=1;i<=n;i++)
	//	printf("%s\n",st[i].a);
	
}
int main()
{
	int n,i,j=1;
	while(scanf("%d",&n)&&n!=0)
	{
		getchar();
		for(i=1;i<=n;i++)
		{
			scanf("%s",st[i].a);
			st[i].len=strlen(st[i].a);
		}
		printf("SET %d\n",j);
		j++;
		fun(n);
		for(i=1;i<=n;i++)
		{
			if(i%2!=0)
			{
				printf("%s\n",st[i].a);
			}
			
		}
		for(i=n;i>0;i--)
		{
			if(i%2==0)
				printf("%s\n",st[i].a);
		}
		
	}
	return 0;
}


对称排列

标签:des   style   io   color   ar   os   sp   for   数据   

原文地址:http://blog.csdn.net/yzi_angel/article/details/41013129

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!