码迷,mamicode.com
首页 > 其他好文 > 详细

入栈和出栈的基本操作

时间:2020-11-10 11:15:01      阅读:5      评论:0      收藏:0      [点我收藏+]

标签:base   rgba   sqs   ace   输入   color   ret   else   一个   

描述

 

输入一个整数序列a1,a2,a3...,an。当ai不等于-1时将ai进栈;当ai=-1时,输出栈顶元素并将其出栈。

 

输入

多组数据,每组数据有两行,第一行为序列的长度n,第二行为n个整数,整数之间用空格分隔。当n=0时输入结束。

输出

对于每一组数据输出若干行。每行为相应的出栈元素。当出栈异常时,输出“POP ERROR”并结束本组数据的输出。

输入样例 1 

5
1 2 -1 -1 1
5
1 -1 -1 2 2
0

输出样例 1

2
1
1
POP ERROR


最基本的常规栈操作,没啥可说的

#include<iostream>
using namespace std;

#define MAXSIZE 1000
#define OK 1
#define ERROR -1

typedef struct{
    int *base;
    int *top;
    int stacksize;
}SqStack;

int InitStack(SqStack &S){
    S.base=new int[MAXSIZE];
    if(!S.base)
        return -2;
    S.top=S.base;
    S.stacksize=MAXSIZE;
    return OK;
}

int Push(SqStack &S,int e){
    if(S.top-S.base==S.stacksize)
        return ERROR;
    *S.top++=e;
    return OK;
}

int Pop(SqStack &S){
    if(S.top==S.base)
        return ERROR;
    S.top--;
    return OK;
}

int GetTop(SqStack &S){
    if(S.top!=S.base)
        return *(S.top-1);
}

int main(){
    while(1){
        int n;
        cin>>n;
        SqStack S;
        if(n==0)
            return 0;
        InitStack(S);
        int a[MAXSIZE];
        for(int i=0;i<n;i++)
            cin>>a[i];
        for(int i=0;i<n;i++){
            if(a[i]!=-1)
                Push(S,a[i]);
            else{
                if(S.top!=S.base){
                    cout<<GetTop(S)<<endl;
                    Pop(S);
                }
                else{
                    cout<<"POP ERROR"<<endl;
                    break;
                }    
            }
        }
    }
}

 

入栈和出栈的基本操作

标签:base   rgba   sqs   ace   输入   color   ret   else   一个   

原文地址:https://www.cnblogs.com/director-yu-youki/p/13951266.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!