码迷,mamicode.com
首页 > 其他好文 > 详细

POJ1862 Stripies 【贪心】

时间:2014-11-12 23:09:46      阅读:388      评论:0      收藏:0      [点我收藏+]

标签:poj1862

Stripies
Time Limit: 1000MS   Memory Limit: 30000K
Total Submissions: 12522   Accepted: 5929

Description

Our chemical biologists have invented a new very useful form of life called stripies (in fact, they were first called in Russian - polosatiki, but the scientists had to invent an English name to apply for an international patent). The stripies are transparent amorphous amebiform creatures that live in flat colonies in a jelly-like nutrient medium. Most of the time the stripies are moving. When two of them collide a new stripie appears instead of them. Long observations made by our scientists enabled them to establish that the weight of the new stripie isn‘t equal to the sum of weights of two disappeared stripies that collided; nevertheless, they soon learned that when two stripies of weights m1 and m2 collide the weight of resulting stripie equals to 2*sqrt(m1*m2). Our chemical biologists are very anxious to know to what limits can decrease the total weight of a given colony of stripies. 
You are to write a program that will help them to answer this question. You may assume that 3 or more stipies never collide together. 

Input

The first line of the input contains one integer N (1 <= N <= 100) - the number of stripies in a colony. Each of next N lines contains one integer ranging from 1 to 10000 - the weight of the corresponding stripie.

Output

The output must contain one line with the minimal possible total weight of colony with the accuracy of three decimal digits after the point.

Sample Input

3
72
30
50

Sample Output

120.000

Source

Northeastern Europe 2001, Northern Subregion

贪心方法是把大数尽量多开方几次,所以每次选择最大的两个数拿出来开方。因为开方对于大数变小的幅度更大,所以对它多开方,-_-|||应该大概是这个道理吧...

#include <stdio.h>
#include <string.h>
#include <algorithm>
#include <math.h>

#define maxn 102

double arr[maxn], ans;

double cal(double a, double b) {
    return 2.0 * sqrt(a * b);
}

int main() {
    int i, j, n;
    scanf("%d", &n);
    for(i = 0; i < n; ++i)
        scanf("%lf", &arr[i]);
    std::sort(arr, arr + n);
    ans = arr[--n];
    while(n) ans = cal(ans, arr[--n]);
    printf("%.3f\n", ans);
    return 0;
}


POJ1862 Stripies 【贪心】

标签:poj1862

原文地址:http://blog.csdn.net/chang_mu/article/details/41050661

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!