标签:form cpp == inpu space ace 就是 using dia
Given an increasing sequence S of N integers, the median is the number at the middle position. For example, the median of S1 = { 11, 12, 13, 14 } is 12, and the median of S2 = { 9, 10, 15, 16, 17 } is 15. The median of two sequences is defined to be the median of the nondecreasing sequence which contains all the elements of both sequences. For example, the median of S1 and S2 is 13.
Given two increasing sequences of integers, you are asked to find their median.
Input Specification:
Each input file contains one test case. Each case occupies 2 lines, each gives the information of a sequence. For each sequence, the first positive integer N (≤2×10?5??) is the size of that sequence. Then N integers follow, separated by a space. It is guaranteed that all the integers are in the range of long int.
Output Specification:
For each test case you should output the median of the two given sequences in a line.
Sample Input:
4 11 12 13 14
5 9 10 15 16 17
Sample Output:
13
思路:这种给N个有序序列找中位数的方法用two point的方法去求解,对于有序序列找特定位置的数的时候主要思路就是two point或者二分思想,前者主要是双指针策略,一个指针指向一个序列,另一个指针指向另外一个序列,逐个判断进行移动。
代码实现:
#include <iostream>
#include <vector>
#include <cmath>
using namespace std;
int main() {
int n,m,val;
cin>>n;
vector<int> s1(n+1);
for(int i=1; i<=n; i++) {
scanf("%d",&s1[i]);
}
cin>>m;
vector<int> s2(m+1);
for(int i=1; i<=m; i++) {
scanf("%d",&s2[i]);
}
int idx1=1,idx2=1,mid=(n+m+1)/2,ans,cnt=0;//mid是中位数的位置
while(idx1<=n&&idx2<=m) {
cnt++;
if(cnt==mid) {
ans=min(s1[idx1],s2[idx2]);
break;
}
if(s1[idx1]<s2[idx2]) idx1++;
else idx2++;
}
if(cnt<=mid) {
//当一个序列遍历完但是还没找到中位数的时候 说明中位数在剩余没遍历完的序列中
while(idx1<=n) {
cnt++;
if(cnt==mid) {
ans=s1[idx1];
break;
}
idx1++;
}
while(idx2<=m) {
cnt++;
if(cnt==mid) {
ans=s2[idx2];
break;
}
idx2++;
}
}
printf("%d",ans);
return 0;
}
标签:form cpp == inpu space ace 就是 using dia
原文地址:https://www.cnblogs.com/coderJ-one/p/14305225.html