码迷,mamicode.com
首页 > 其他好文 > 详细

Digit Counting UVA - 1225

时间:2021-02-01 12:17:16      阅读:0      评论:0      收藏:0      [点我收藏+]

标签:nts   pie   hal   win   rate   --   ant   hat   seq   

?   Trung is bored with his mathematics homeworks. He takes a piece of chalk and starts writing a sequence of consecutive integers starting with 1 to N (1 < N < 10000). After that, he counts the number of times each digit (0 to 9) appears in the sequence. For example, with N = 13, the sequence is: 12345678910111213

?   In this sequence, 0 appears once, 1 appears 6 times, 2 appears 2 times, 3 appears 3 times, and each digit from 4 to 9 appears once. After playing for a while, Trung gets bored again. He now wants to write a program to do this for him. Your task is to help him with writing this program.

Input

?   The input file consists of several data sets. The first line of the input file contains the number of data sets which is a positive integer and is not bigger than 20. The following lines describe the data sets.

?   For each test case, there is one single line containing the number N.

Output

?   For each test case, write sequentially in one line the number of digit 0, 1, . . . 9 separated by a space.

Sample Input

2
3
13

Sample Output

0 1 1 1 0 0 0 0 0 0
1 6 2 2 1 1 1 1 1 1

HINT

直接暴力破解~

Accepted

#include<stdio.h>
#include<string.h>

int main()
{
	int sum;
	scanf("%d", &sum);
	while (sum--)
	{
		int num;
		int arr[10] = { 0 };
		scanf("%d", &num);
		for (int i = 1;i <= num;i++)
		{
			int a, b;
			a = i;
			while (a)
			{
				b = a % 10;
				a  /= 10;
				arr[b]++;
			}
		}
		for (int i = 0;i < 9;i++)
			printf("%d ", arr[i]);
		printf("%d\n", arr[9]);
	}
}

Digit Counting UVA - 1225

标签:nts   pie   hal   win   rate   --   ant   hat   seq   

原文地址:https://www.cnblogs.com/3236676588buladuo/p/14350310.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!