码迷,mamicode.com
首页 > 其他好文 > 详细

hdu 4662 MU Puzzle

时间:2014-05-18 04:16:16      阅读:407      评论:0      收藏:0      [点我收藏+]

标签:acm   算法   algorithm   hdu   数学   

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=4662

MU Puzzle

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1296    Accepted Submission(s): 539


Problem Description
Suppose there are the symbols M, I, and U which can be combined to produce strings of symbols called "words". We start with one word MI, and transform it to get a new word. In each step, we can use one of the following transformation rules:
1. Double any string after the M (that is, change Mx, to Mxx). For example: MIU to MIUIU.
2. Replace any III with a U. For example: MUIIIU to MUUU.
3. Remove any UU. For example: MUUU to MU.
Using these three rules is it possible to change MI into a given string in a finite number of steps?
 

Input
First line, number of strings, n. 
Following n lines, each line contains a nonempty string which consists only of letters ‘M‘, ‘I‘ and ‘U‘. 

Total length of all strings <= 106.
 

Output
n lines, each line is ‘Yes‘ or ‘No‘.
 

Sample Input
2 MI MU
 

Sample Output
Yes No
 

Source
 

Recommend
zhuyuanchen520   |   We have carefully selected several similar problems for you:  4822 4821 4820 4819 4818 
 

规律题,把u全部化成i,然后多写下,就能发现规律

#include<iostream>
#include<cstring>
using namespace std;
char str[1000010];
int main()
{
	int n;
	cin>>n;
	while(n--)
	{
		cin>>str;
		int l=strlen(str),xi=0,xu=0,k=0;
		if(str[0]!=‘M‘)
		{
			cout<<"No"<<endl;
			continue;
		}
		for(int i=1;i<l;i++)
		{
			if(str[i]==‘I‘)
			    xi++;
			else if(str[i]==‘U‘)
			    xu++;
			else
			{
				k=1;
				break;
			}
		}
		if(k==1 || ((xi+xu)%2==1 && !(xi==1 && xu==0)) || xi%3==0)
		{
			cout<<"No"<<endl;
			continue;
		}
		else
		{
			cout<<"Yes"<<endl;
			continue;
		}	
	}
	return 0;
}


hdu 4662 MU Puzzle,布布扣,bubuko.com

hdu 4662 MU Puzzle

标签:acm   算法   algorithm   hdu   数学   

原文地址:http://blog.csdn.net/asdfghjkl1993/article/details/26010741

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!