码迷,mamicode.com
首页 > 其他好文 > 详细

树3 Tree Traversals Again 代码

时间:2021-04-27 14:18:22      阅读:0      评论:0      收藏:0      [点我收藏+]

标签:for   lex   item   元素   order   osi   justify   exactly   bin   

03-树3 Tree Traversals Again (25 分)
 

An inorder binary tree traversal can be implemented in a non-recursive way with a stack. For example, suppose that when a 6-node binary tree (with the keys numbered from 1 to 6) is traversed, the stack operations are: push(1); push(2); push(3); pop(); pop(); push(4); pop(); pop(); push(5); push(6); pop(); pop(). Then a unique binary tree (shown in Figure 1) can be generated from this sequence of operations. Your task is to give the postorder traversal sequence of this tree.

技术图片
Figure 1

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (≤) which is the total number of nodes in a tree (and hence the nodes are numbered from 1 to N). Then 2 lines follow, each describes a stack operation in the format: "Push X" where X is the index of the node being pushed onto the stack; or "Pop" meaning to pop one node from the stack.

Output Specification:

For each test case, print the postorder traversal sequence of the corresponding tree in one line. A solution is guaranteed to exist. All the numbers must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input:

6
Push 1
Push 2
Push 3
Pop
Pop
Push 4
Pop
Pop
Push 5
Push 6
Pop
Pop
 

Sample Output:

3 4 2 6 5 1

 

 

#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <iostream>
#include <stack>

using namespace std;

typedef int elemType;

typedef struct BTreeNode{
    elemType data;
    int flag;
    struct BTreeNode *lchild, *rchild;
}*Bitree;

stack<Bitree> bst;
Bitree tempNode = NULL;
int printflag=1;

void popNode(){
    tempNode = bst.top();
    bst.pop();
}

void pushNode1(elemType udata){
    Bitree T;
    T=(Bitree)malloc(sizeof(BTreeNode));
    T->data = udata;
    bst.top()->lchild=T;
    bst.push(T);

    T->lchild = NULL;
    T->rchild = NULL;
}

void pushNode2(elemType udata){
    Bitree T;
    T=(Bitree)malloc(sizeof(BTreeNode));
    T->data = udata;
    tempNode->rchild=T;
    bst.push(T);

    T->lchild = NULL;
    T->rchild = NULL;
}

void initTree(Bitree &T, elemType udata){
    T=(Bitree)malloc(sizeof(BTreeNode));
    T->data = udata;
    bst.push(T);

    T->lchild = NULL;
    T->rchild = NULL;
}

void pri(Bitree T){
    if(T){
        pri(T->lchild);
        pri(T->rchild);
        if(printflag){
            printflag = 0;
            cout << T->data;
        }else{
            cout << " " << T->data;
        }
    }
}

int main()
{
    int status=-1, udata, n;
    char opin[20];
    Bitree T;
    //-1 初态
    //1 push之后push,在顶的左边
    //2 pop之后push,在pop出的元素右边
    cin >> n;
    for(int i=0; i<2*n; i++){
        cin >> opin;

        if(!strcmp(opin, "Push")){
            cin >> udata;
            if(status == -1) initTree(T, udata);
            else if(status == 1) pushNode1(udata);
            else if(status == 2) pushNode2(udata);
            status = 1;
        }else if(!strcmp(opin, "Pop")){
            popNode();
            status = 2;
        }
    }

    pri(T);


    //cout << "Hello world!" << endl;
    return 0;
}

 

树3 Tree Traversals Again 代码

标签:for   lex   item   元素   order   osi   justify   exactly   bin   

原文地址:https://www.cnblogs.com/wstnl/p/14702647.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!