标签:des style http io color ar os sp java
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 8166 Accepted Submission(s): 5998
Problem Description
Given an positive integer A (1 <= A <= 100), output the lowest bit of A.
For example, given A = 26, we can write A in binary form as 11010, so the lowest bit of A is 10, so the output should be 2.
Another example goes like this: given A = 88, we can write A in binary form as 1011000, so the lowest bit of A is 1000, so the output should be 8.
Input
Each line of input contains only an integer A (1 <= A <= 100). A line containing "0" indicates the end of input, and this line is not a part of the input data.
Output
For each A in the input, output a line containing only its lowest bit.
Sample Input
Sample Output
Author
SHI, Xiaohan
Source
题意:求一个十进制数的二进制形式的从最后一个不为0的位开始算起的后面的二进制代表的十进制数是多少。
解题思路:利用位运算,用 & 1 判断一个数的二进制形式的最后一位是否为一,每次右移一位,用k纪录右移的次数,重复判断最后一位是否为1,若是1,则要求的结果就是2^k,输出即可。不过注意,在第一次右移前,要先判断原来的数是否为奇数。
AC代码:
#include <iostream>
#include <cstdio>
#include <string>
using namespace std;
int main(){
// freopen("in.txt", "r", stdin);
int a;
while(scanf("%d", &a)!=EOF && a){
int k = 0; //右移位数
while(1){
if(a & 1){
printf("%d\n", (1<<k));
break;
}
a >>= 1;
k ++;
}
}
return 0;
}
HDU 1196 Lowest Bit (数位)
标签:des style http io color ar os sp java
原文地址:http://blog.csdn.net/u013446688/article/details/41123179