码迷,mamicode.com
首页 > 其他好文 > 详细

HDU 3079 Vowel Counting (水)

时间:2014-11-14 21:15:14      阅读:168      评论:0      收藏:0      [点我收藏+]

标签:des   style   http   io   color   ar   os   sp   java   

Vowel Counting

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1413    Accepted Submission(s): 1043


Problem Description
The "Vowel-Counting-Word"(VCW), complies with the following conditions.
Each vowel in the word must be uppercase. 
Each consonant (the letters except the vowels) must be lowercase.
For example, "ApplE" is the VCW of "aPPle", "jUhUA" is the VCW of "Juhua".
Give you some words; your task is to get the "Vowel-Counting-Word" of each word.
 

Input
The first line of the input contains an integer T (T<=20) which means the number of test cases.
For each case, there is a line contains the word (only contains uppercase and lowercase). The length of the word is not greater than 50.
 

Output
For each case, output its Vowel-Counting-Word.
 

Sample Input
4 XYz application qwcvb aeioOa
 

Sample Output
xyz ApplIcAtIOn qwcvb AEIOOA





解题思路:水题一枚,字符大小写转化问题。






AC代码:

#include <iostream>
#include <cstdio>
#include <string>
using namespace std;

int main(){
//    freopen("in.txt", "r", stdin);
    int t;
    string s;
    while(scanf("%d", &t)!=EOF){
        cin>>s;
        for(int i=0; i<s.size(); i++){
            if(s[i] == 'a' || s[i] == 'e' || s[i] == 'i' || s[i] == 'o' || s[i] == 'u' || s[i] == 'A' || s[i] == 'E' || s[i] == 'I' || s[i] == 'O' || s[i] == 'U'){
                if(s[i]>='a' && s[i]<='z')  s[i] -= 32;
                printf("%c", s[i]);    
            }
            else{
                if(s[i]>='A' && s[i]<='Z')  s[i] += 32;
                printf("%c", s[i]);    
            }
        }
        printf("\n");    
    }
    return 0;
}


HDU 3079 Vowel Counting (水)

标签:des   style   http   io   color   ar   os   sp   java   

原文地址:http://blog.csdn.net/u013446688/article/details/41122979

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!