码迷,mamicode.com
首页 > 其他好文 > 详细

poj--3086

时间:2014-05-19 19:50:24      阅读:191      评论:0      收藏:0      [点我收藏+]

标签:style   blog   class   c   code   tar   

escription

The nth Triangular number, T(n) = 1 + … + n, is the sum of the first n integers. It is the number of points in a triangular array with n points on side. For example T(4):

X X X X X X X X X X

Write a program to compute the weighted sum of triangular numbers:

W(n) = SUM[k = 1…n; k * T(k + 1)]

Input

The first line of input contains a single integer N, (1 ≤ N ≤ 1000) which is the number of datasets that follow.

Each dataset consists of a single line of input containing a single integer n, (1 ≤ n ≤300), which is the number of points on a side of the triangle.

Output

For each dataset, output on a single line the dataset number (1 through N), a blank, the value of n for the dataset, a blank, and the weighted sum ,W(n), of triangular numbers for n.

Sample Input

4
3
4
5
10

Sample Output

 

1 3 45
2 4 105
3 5 210
4 10 2145

具体代码:

 

bubuko.com,布布扣
#include <iostream>
#include <cstdio>
#include <cstdlib>
#include <cstring>
using namespace std;

int main()
{
    int t, n;
    scanf("%d", &t);
    for (int i = 0; i < t; i++)
    {
        scanf("%d", &n);
        int w = 0, x = 1;
        for (int j = 1; j <= n; j++)
        {
            x += j + 1;
            w += j * x;
        }
        printf("%d %d %d\n", i + 1, n, w);
    }
    return 0;
}
View Code

 

 

 

poj--3086,布布扣,bubuko.com

poj--3086

标签:style   blog   class   c   code   tar   

原文地址:http://www.cnblogs.com/baoluqi/p/3734556.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!