码迷,mamicode.com
首页 > 其他好文 > 详细

POJ1017 Packets 【贪心】

时间:2014-11-15 00:13:01      阅读:195      评论:0      收藏:0      [点我收藏+]

标签:poj1017

Packets
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 44505   Accepted: 15032

Description

A factory produces products packed in square packets of the same height h and of the sizes 1*1, 2*2, 3*3, 4*4, 5*5, 6*6. These products are always delivered to customers in the square parcels of the same height h as the products have and of the size 6*6. Because of the expenses it is the interest of the factory as well as of the customer to minimize the number of parcels necessary to deliver the ordered products from the factory to the customer. A good program solving the problem of finding the minimal number of parcels necessary to deliver the given products according to an order would save a lot of money. You are asked to make such a program.

Input

The input file consists of several lines specifying orders. Each line specifies one order. Orders are described by six integers separated by one space representing successively the number of packets of individual size from the smallest size 1*1 to the biggest size 6*6. The end of the input file is indicated by the line containing six zeros.

Output

The output file contains one line for each line in the input file. This line contains the minimal number of parcels into which the order from the corresponding line of the input file can be packed. There is no line in the output file corresponding to the last ``null‘‘ line of the input file.

Sample Input

0 0 4 0 0 1 
7 5 1 0 0 0 
0 0 0 0 0 0 

Sample Output

2 
1 

Source

参考自:click

#include <stdio.h>
#include <string.h>

int main() {
    int a, b, c, d, e, f, ans, tmp;
    const int sam[] = {0, 5, 3, 1};
    while(scanf("%d%d%d%d%d%d", &a, &b, &c, &d, &e, &f), a|b|c|d|e|f) {
        ans = f + e + d + (c + 3) / 4;
        tmp = d * 5 + sam[c % 4];
        if(b > tmp) ans += (b - tmp + 8) / 9;
        tmp = ans * 36 - f * 36 - e * 25 - d * 16 - c * 9 - b * 4;
        if(a > tmp) ans += (a - tmp + 35) / 36;
        printf("%d\n", ans);
    }
    return 0;
}


POJ1017 Packets 【贪心】

标签:poj1017

原文地址:http://blog.csdn.net/chang_mu/article/details/41130361

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!