码迷,mamicode.com
首页 > 其他好文 > 详细

Hdu 2178 猜数字

时间:2014-11-15 00:17:04      阅读:221      评论:0      收藏:0      [点我收藏+]

标签:des   style   io   color   ar   os   sp   java   strong   

猜数字

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 3415    Accepted Submission(s): 2458


Problem Description
A有1数m,B来猜.B每猜一次,A就说"太大","太小"或"对了" 。 
问B猜n次可以猜到的最大数。 
 

Input
第1行是整数T,表示有T组数据,下面有T行 
每行一个整数n (1 ≤ n ≤ 30) 
 

Output
猜n次可以猜到的最大数
 

Sample Input
2 1 3
 

Sample Output
1 7
 


求猜n次最大能猜到的数字,感觉像一种二分的思想,一个数字你要猜到它,最少猜log2(m)+1次就够了,所以在n次之内能猜到的最大数,就是2^n-1

#include <iostream>
#include <stdio.h>
#include <string>
#include <cstring>
#include <cmath>
#include <algorithm>
#define N 100
using namespace std;

int main()
{
    int t,n;
    scanf("%d",&t);

        while(t--)
        {
            scanf("%d",&n);
            printf("%d\n",(int)pow(2,n)-1);
        }

    return 0;
}







Hdu 2178 猜数字

标签:des   style   io   color   ar   os   sp   java   strong   

原文地址:http://blog.csdn.net/wust_zjx/article/details/41127173

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!