码迷,mamicode.com
首页 > 其他好文 > 详细

poj 1050

时间:2014-11-15 16:56:14      阅读:156      评论:0      收藏:0      [点我收藏+]

标签:des   blog   http   io   ar   os   sp   for   strong   

To the Max
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 41322   Accepted: 21917

Description

Given a two-dimensional array of positive and negative integers, a sub-rectangle is any contiguous sub-array of size 1*1 or greater located within the whole array. The sum of a rectangle is the sum of all the elements in that rectangle. In this problem the sub-rectangle with the largest sum is referred to as the maximal sub-rectangle. 
As an example, the maximal sub-rectangle of the array: 

0 -2 -7 0 
9 2 -6 2 
-4 1 -4 1 
-1 8 0 -2 
is in the lower left corner: 

9 2 
-4 1 
-1 8 
and has a sum of 15. 

Input

The input consists of an N * N array of integers. The input begins with a single positive integer N on a line by itself, indicating the size of the square two-dimensional array. This is followed by N^2 integers separated by whitespace (spaces and newlines). These are the N^2 integers of the array, presented in row-major order. That is, all numbers in the first row, left to right, then all numbers in the second row, left to right, etc. N may be as large as 100. The numbers in the array will be in the range [-127,127].

Output

Output the sum of the maximal sub-rectangle.

Sample Input

4
0 -2 -7 0 9 2 -6 2
-4 1 -4  1 -1

8  0 -2

Sample Output

15

Source

Greater New York 2001
#include<iostream>
#include<cstdio>
#include<cstring>
#include<string>
#include<cmath>
#include<algorithm>
#include<cstdlib>
#include<queue>
#include<vector>
#include<set>
using namespace std;
int n,a[102][102],v[102][102],maxx,ans;
int main()
{
      while(scanf("%d",&n)!=EOF)
      {
            maxx=0,ans=0;
            for(int i=1;i<=n;i++)
                  for(int j=1;j<=n;j++)
                  {
                       scanf("%d",&a[i][j]);
                       v[i][j]=v[i-1][j]+a[i][j];
                  }
            for(int i=1;i<=n;i++)
            {
                  for(int j=i;j<=n;j++)
                  {
                       ans=0;
                       for(int k=1;k<=n;k++)
                       {
                          if(ans>0)
                            ans+=v[j][k]-v[i-1][k];
                          else
                            ans=v[j][k]-v[i-1][k];
                          if(ans>maxx)
                              maxx=ans;
                       }

                  }
            }
            printf("%d\n",maxx);

      }
      return 0;
}

  

poj 1050

标签:des   blog   http   io   ar   os   sp   for   strong   

原文地址:http://www.cnblogs.com/a972290869/p/4099511.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!