码迷,mamicode.com
首页 > 其他好文 > 详细

poj 2823

时间:2014-11-15 17:03:12      阅读:141      评论:0      收藏:0      [点我收藏+]

标签:des   style   blog   http   io   ar   os   sp   for   

Sliding Window
Time Limit: 12000MS   Memory Limit: 65536K
Total Submissions: 40443   Accepted: 11950
Case Time Limit: 5000MS

Description

An array of size n ≤ 106 is given to you. There is a sliding window of size k which is moving from the very left of the array to the very right. You can only see the k numbers in the window. Each time the sliding window moves rightwards by one position. Following is an example: 
The array is [1 3 -1 -3 5 3 6 7], and k is 3.
Window positionMinimum valueMaximum value
[1  3  -1] -3  5  3  6  7  -1 3
 1 [3  -1  -3] 5  3  6  7  -3 3
 1  3 [-1  -3  5] 3  6  7  -3 5
 1  3  -1 [-3  5  3] 6  7  -3 5
 1  3  -1  -3 [5  3  6] 7  3 6
 1  3  -1  -3  5 [3  6  7] 3 7

Your task is to determine the maximum and minimum values in the sliding window at each position. 

Input

The input consists of two lines. The first line contains two integers n and k which are the lengths of the array and the sliding window. There are n integers in the second line. 

Output

There are two lines in the output. The first line gives the minimum values in the window at each position, from left to right, respectively. The second line gives the maximum values. 

Sample Input

8 3
1 3 -1 -3 5 3 6 7

Sample Output

-1 -3 -3 -3 3 3
3 3 5 5 6 7

Source

POJ Monthly--2006.04.28, Ikki
#include<iostream>
#include<cstdio>
#include<cstring>
#include<string>
#include<cmath>
#include<queue>
#include<cstdlib>
#include<vector>
#include<set>
#include<queue>
using namespace std;
int a[1000000];
int aa[1000000];
int bb[1000000];
int n,s;
struct cmp1
{
    bool operator()(const int a1,const int a2)
    {
        return a[a1]>a[a2];
    }
};
struct cmp2
{
    bool operator()(const int a1,const int a2)
    {
        return a[a1]<a[a2];
    }
};
priority_queue<int,vector<int>,cmp1>q1;
priority_queue<int,vector<int>,cmp2>q2;

int main()
{
      scanf("%d%d",&n,&s);
      int i,cnt1=0,cnt2=0;
      for(i=0;i<n;i++)
            scanf("%d",&a[i]);
      for(i=0;i<s;i++)
      {
            q1.push(i);
            q2.push(i);
      }
      aa[cnt1++]=a[q1.top()];
      bb[cnt2++]=a[q2.top()];
      for(i=s;i<n;i++)
      {
            q1.push(i);
            q2.push(i);
            while(i-q1.top()>=s)
                  q1.pop();
            aa[cnt1++]=a[q1.top()];
            while(i-q2.top()>=s)
                  q2.pop();
            bb[cnt2++]=a[q2.top()];
      }
      printf("%d",aa[0]);
      for(i=1;i<n-s+1;i++)
            printf(" %d",aa[i]);
      printf("\n");
      printf("%d",bb[0]);
      for(i=1;i<n-s+1;i++)
            printf(" %d",bb[i]);
      printf("\n");
      return 0;
}

  

poj 2823

标签:des   style   blog   http   io   ar   os   sp   for   

原文地址:http://www.cnblogs.com/a972290869/p/4099525.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!