码迷,mamicode.com
首页 > 其他好文 > 详细

poj 2533

时间:2014-11-15 18:22:13      阅读:162      评论:0      收藏:0      [点我收藏+]

标签:des   blog   io   ar   os   sp   for   strong   div   

Longest Ordered Subsequence
Time Limit: 2000MS   Memory Limit: 65536K
Total Submissions: 34440   Accepted: 15128

Description

A numeric sequence of ai is ordered if a1 < a2 < ... < aN. Let the subsequence of the given numeric sequence (a1a2, ..., aN) be any sequence (ai1ai2, ..., aiK), where 1 <= i1 < i2 < ... < iK <= N. For example, sequence (1, 7, 3, 5, 9, 4, 8) has ordered subsequences, e. g., (1, 7), (3, 4, 8) and many others. All longest ordered subsequences are of length 4, e. g., (1, 3, 5, 8).

Your program, when given the numeric sequence, must find the length of its longest ordered subsequence.

Input

The first line of input file contains the length of sequence N. The second line contains the elements of sequence - N integers in the range from 0 to 10000 each, separated by spaces. 1 <= N <= 1000

Output

Output file must contain a single integer - the length of the longest ordered subsequence of the given sequence.

Sample Input

7
1 7 3 5 9 4 8

Sample Output

4

Source

#include<iostream>
#include<cstdio>
#include<cstring>
#include<string>
#include<cstdlib>
#include<cmath>
#include<algorithm>
#include<queue>
#include<vector>
#include<set>
using namespace std;
int n,a[1005],dp[1005],ans;
int main()
{
while(scanf("%d",&n)!=EOF)
{
ans=1;
memset(dp,0,sizeof(dp));
for(int i=1;i<=n;i++)
scanf("%d",&a[i]);
for(int i=1;i<=n;i++)
dp[i]=1;
for(int i=2;i<=n;i++)
for(int j=1;j<i;j++)
if(a[j]<a[i]&&dp[i]<=dp[j])
dp[i]=dp[j]+1;
for(int i=1;i<=n;i++)
if(ans<dp[i])
ans=dp[i];
printf("%d\n",ans);
}
return 0;
}

  

poj 2533

标签:des   blog   io   ar   os   sp   for   strong   div   

原文地址:http://www.cnblogs.com/a972290869/p/4099611.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!