码迷,mamicode.com
首页 > 其他好文 > 详细

nyoj 712

时间:2014-11-15 18:49:15      阅读:196      评论:0      收藏:0      [点我收藏+]

标签:blog   io   ar   os   sp   for   数据   div   on   

探 寻 宝 藏

时间限制:1000 ms  |  内存限制:65535 KB
难度:5
 
描述

传说HMH大沙漠中有一个M*N迷宫,里面藏有许多宝物。某天,Dr.Kong找到了迷宫的地图,他发现迷宫内处处有宝物,最珍贵的宝物就藏在右下角,迷宫的进出口在左上角。当然,迷宫中的通路不是平坦的,到处都是陷阱。Dr.Kong决定让他的机器人卡多去探险。

但机器人卡多从左上角走到右下角时,只会向下走或者向右走。从右下角往回走到左上角时,只会向上走或者向左走,而且卡多不走回头路。(即:一个点最多经过一次)。当然卡多顺手也拿走沿路的每个宝物。

Dr.Kong希望他的机器人卡多尽量多地带出宝物。请你编写程序,帮助Dr.Kong计算一下,卡多最多能带出多少宝物。
 
输入
第一行: K 表示有多少组测试数据。 
接下来对每组测试数据:
第1行: M N
第2~M+1行: Ai1 Ai2 ……AiN (i=1,…..,m)


【约束条件】
2≤k≤5 1≤M, N≤50 0≤Aij≤100 (i=1,….,M; j=1,…,N)
所有数据都是整数。 数据之间有一个空格。
输出
对于每组测试数据,输出一行:机器人卡多携带出最多价值的宝物数
样例输入
2
2 3
0 10 10
10 10 80
3 3
0 3 9
2 8 5
5 7 100
样例输出
120
134
#include <iostream>
#include <cstring>
#include <cstdio>
#include <iostream>
#include <cmath>
#include <cstdlib>
using namespace std;
const int M = 52;
int map[M][M];
int dp[M+M][M][M]; // dp[k][i][j]: 第k步时,双线里 一线在i位置(横坐标为i,纵坐标为k-i) 另一线在j位置(横坐标为j,纵坐标为k-j)的最大和

int main()
{
    int T;cin >> T;
    while(T--){
        int row , col;
        cin >> row >> col;
        memset(dp,0,sizeof(dp));
        for(int i = 1 ; i <= row ; i++)
            for(int j = 1 ; j <= col ; j++)
                scanf("%d" , &map[i][j]);
int beg = map[1][1];
int end = map[row][col];
map[1][1] = map[row][col] = 0;
        int bound = col + row;
        for(int k = 1 ; k <= bound ; k++){ // 起点和终点为唯一交叉处,特判
            for(int x1 = 1 ; x1 <= row ; x1++){
                for(int x2 = 1 ; x2 <= row ; x2++){
                    if (x1 == x2 && !(k==bound && x1==row))continue;
                    int y1 = k - x1;
                    int y2 = k - x2;
                    if ( !(1<=y1 && y1<=col) || !(1<=y2 && y2<=col))continue;
                    dp[k][x1][x2] = max(max(dp[k-1][x1-1][x2-1],
                                        dp[k-1][ x1 ][x2-1]),
                                        max(dp[k-1][x1-1][ x2 ],
                                        dp[k-1][ x1 ][ x2 ]));
                    dp[k][x1][x2] += map[x1][y1] + map[x2][y2];
                }
            }
        }
        cout << beg + dp[bound][row][row] + end << endl;
    }
    return 0;
}

  

nyoj 712

标签:blog   io   ar   os   sp   for   数据   div   on   

原文地址:http://www.cnblogs.com/a972290869/p/4099944.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!