码迷,mamicode.com
首页 > 其他好文 > 详细

nyoj 269

时间:2014-11-15 18:50:01      阅读:163      评论:0      收藏:0      [点我收藏+]

标签:blog   http   io   ar   os   sp   for   div   on   

VF

时间限制:1000 ms  |  内存限制:65535 KB
难度:2
 
描述
Vasya is the beginning mathematician. He decided to make an important contribution to the science and to become famous all over the world. But how can he do that if the most interesting facts such as Pythagor’s theorem are already proved? Correct! He is to think out something his own, original. So he thought out the Theory of Vasya’s Functions. Vasya’s Functions (VF) are rather simple: the value of the Nth VF in the point S is an amount of integers from 1 to N that have the sum of digits S. You seem to be great programmers, so Vasya gave you a task to find the milliard VF value (i.e. the VF with N = 109) because Vasya himself won’t cope with the task. Can you solve the problem?
 
输入
There are multiple test cases.
Integer S (1 ≤ S ≤ 81).
输出
The milliard VF value in the point S.
样例输入
1
样例输出
10
来源
USU Junior Championship March‘2005
上传者
李文鑫

 

/*
思路:题目意思就是求1~1000000000之间数字之和等于s
状态方程 :d[i]][j]=d[i][j]+d[i-1][j-k] (0<=k<=j&&k<=9)
d[i][j]表示i位的数字之和等于j
推导:(数字之和等于j 的个数) =
(i位数字之和等于j的个数) + (i-1位数字之和j-k的个数)
*/
#include<iostream>
#include<cstdio>
#include<cstring>
#include<string>
#include<cmath>
#include<cstdlib>
#include<algorithm>
using namespace std;
int dp[10][100],n;
int main()
{
    for(int i=1;i<10;i++)
    dp[1][i]=1;
    for(int i=1;i<10;i++)
        for(int j=1;j<=9*i;j++)
           for(int k=0;k<=j&&k<10;k++)
               dp[i][j]+=dp[i-1][j-k];
    while(scanf("%d",&n)!=EOF)
    {
    
          int ans=0;
          if(n!=1)
          {
             for(int i=1;i<10;i++)
             ans+=dp[i][n];
             printf("%d\n",ans);
          }
          else
          printf("10\n");
    }
    return 0;
}

  

nyoj 269

标签:blog   http   io   ar   os   sp   for   div   on   

原文地址:http://www.cnblogs.com/a972290869/p/4099957.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!