码迷,mamicode.com
首页 > 其他好文 > 详细

nyoj 716

时间:2014-11-15 20:04:34      阅读:198      评论:0      收藏:0      [点我收藏+]

标签:blog   http   io   ar   os   sp   for   div   on   

River Crossing

时间限制:1000 ms  |  内存限制:65535 KB
难度:4
 
描述

Afandi is herding N sheep across the expanses of grassland  when he finds himself blocked by a river. A single raft is available for transportation.

 

Afandi knows that he must ride on the raft for all crossings, but adding sheep to the raft makes it traverse the river more slowly.

 

When Afandi is on the raft alone, it can cross the river in M minutes When the i sheep are added, it takes Mi minutes longer to cross the river than with i-1 sheep (i.e., total M+M1   minutes with one sheep, M+M1+M2 with two, etc.).

 

Determine the minimum time it takes for Afandi to get all of the sheep across the river (including time returning to get more sheep).

 
输入
On the first line of the input is a single positive integer k, telling the number of test cases to follow. 1 ≤ k ≤ 5 Each case contains:

* Line 1: one space-separated integers: N and M (1 ≤ N ≤ 1000 , 1≤ M ≤ 500).

* Lines 2..N+1: Line i+1 contains a single integer: Mi (1 ≤ Mi ≤ 1000)
输出
For each test case, output a line with the minimum time it takes for Afandi to get all of the sheep across the river.
样例输入
2    
2 10   
3
5
5 10  
3
4
6
100
1
样例输出
18
50
来源
第六届河南省程序设计大赛
/*
dp[i]表示人和i只羊一起过河所花费的最短时间 
dp[i]=min(dp[i],dp[i-j]+m+dp[j]);
j:= 1~i-1;
*/ 
#include<stdio.h>
#include<algorithm>
using namespace std;
int dp[1005], t[1005];
int main()
{
    int T, n, m, i, j;
    scanf("%d",&T);
    while(T--)
    {
        int a;
        scanf("%d%d",&n, &m);
        t[0] = 0;
        for(i = 1; i <= n; i++)
        {
            scanf("%d",&a);
            t[i] = t[i-1] + a;
        }
        for(i = 1; i <= n; i++)
        {
            dp[i] = t[i] + m;
            for(j = 1; j < i; j++)
                dp[i] = min(dp[i], dp[i-j] + dp[j] + m);
        }
        printf("%d\n",dp[n]);
    }
    return 0;
}

  

nyoj 716

标签:blog   http   io   ar   os   sp   for   div   on   

原文地址:http://www.cnblogs.com/a972290869/p/4100019.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!