码迷,mamicode.com
首页 > 其他好文 > 详细

nyoj 76

时间:2014-11-15 20:05:59      阅读:153      评论:0      收藏:0      [点我收藏+]

标签:blog   http   io   ar   os   sp   for   数据   div   

超级台阶

时间限制:1000 ms  |  内存限制:65535 KB
难度:3
 
描述

有一楼梯共m级,刚开始时你在第一级,若每次只能跨上一级或二级,要走上第m级,共有多少走法?

注:规定从一级到一级有0种走法。

 
输入
输入数据首先包含一个整数n(1<=n<=100),表示测试实例的个数,然后是n行数据,每行包含一个整数m,(1<=m<=40), 表示楼梯的级数。
输出
对于每个测试实例,请输出不同走法的数量。
样例输入
2
2
3
样例输出
1
2
来源
[苗栋栋]原创
上传者
苗栋栋
#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<cstdlib>
#include<algorithm>
#include<string>
using namespace std;
int t,n,f[45];
void dp()
{
 	for(int i=4;i<=45;i++)
f[i]=f[i-1]+f[i-2];
}
int main()
{
 	scanf("%d",&t);
 	f[1]=0;
 	f[2]=1;
 	f[3]=2;
 	dp();
 	for(int k=1;k<=t;k++)
 	{
scanf("%d",&n);
   printf("%d\n",f[n]);
    }
    return 0;
}

  

nyoj 76

标签:blog   http   io   ar   os   sp   for   数据   div   

原文地址:http://www.cnblogs.com/a972290869/p/4099965.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!