码迷,mamicode.com
首页 > 其他好文 > 详细

nyoj 741

时间:2014-11-15 20:08:28      阅读:202      评论:0      收藏:0      [点我收藏+]

标签:blog   http   io   ar   os   sp   for   div   on   

Splits the string

时间限制:1000 ms  |  内存限制:65535 KB
难度:3
 
描述
Hrdv is interested in a string,especially the palindrome string.So he wants some palindrome string.
 
A sequence of characters is a palindrome if it is the same written forwards and backwards. For example, ‘abeba‘ is a palindrome, but ‘abcd‘ is not.
 
A partition of a sequence of characters is a list of one or more disjoint non-empty groups of consecutive characters whose concatenation yields the initial sequence. For example, (‘race‘, ‘car‘) is a partition of ‘racecar‘ into two groups.
 
Given a sequence of characters, we can always create a partition of these characters such that each group in the partition is a palindrome! Given this observation it is natural to ask: what is the minimum number of groups needed for a given string such that every group is a palindrome?
 
For example:
 
‘racecar‘ is already a palindrome, therefore it can be partitioned into one group.
‘fastcar‘ does not contain any non-trivial palindromes, so it must be partitioned as (‘f‘, ‘a‘, ‘s‘, ‘t‘, ‘c‘, ‘a‘, ‘r‘).
‘aaadbccb‘ can be partitioned as (‘aaa‘, ‘d‘, ‘bccb‘).
Input begins with the number n of test cases. Each test case consists of a single line of between 1 and 1000 lowercase letters, with no whitespace within.
 
 
输入
Each test case consists of a single line of between 1 and 1000 lowercase letters, with no whitespace within.
输出
For each test case, output a line containing the minimum number of groups required to partition the input into groups of palindromes.
样例输入
racecar
fastcar
aaadbccb
样例输出
1
7
3
上传者
TC_胡仁东

 

/*
用dp[i] 记录从0到当前i位置这一段最少由几个回文子串组成,
动态转移方程:dp[i] = min(dp[i],dp[j-1]+1);
*/
#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
char str[1010];
int dp[1010];
bool judge(int x,int y) //判断是不是回文串
{
while(x <= y)
{
if(str[x] != str[y])
return false;
x++;
y--;
}
return true;
}
int main()
{
int len, i, j;
while(gets(str) != NULL)
{
len = strlen(str);
for(i = 0; i < len; i++)
{
dp[i] = i + 1; 
for(j = 0; j <= i; j++)
if(str[j] == str[i] && judge(j,i))
dp[i] = min(dp[i], dp[j-1]+1);
}
printf("%d\n",dp[len-1]);
}
return 0;
}

  

nyoj 741

标签:blog   http   io   ar   os   sp   for   div   on   

原文地址:http://www.cnblogs.com/a972290869/p/4100016.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!