码迷,mamicode.com
首页 > 其他好文 > 详细

poj 1011

时间:2014-11-16 10:34:55      阅读:128      评论:0      收藏:0      [点我收藏+]

标签:des   blog   http   io   ar   os   sp   for   strong   

Sticks
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 122529   Accepted: 28391

Description

George took sticks of the same length and cut them randomly until all parts became at most 50 units long. Now he wants to return sticks to the original state, but he forgot how many sticks he had originally and how long they were originally. Please help him and design a program which computes the smallest possible original length of those sticks. All lengths expressed in units are integers greater than zero.

Input

The input contains blocks of 2 lines. The first line contains the number of sticks parts after cutting, there are at most 64 sticks. The second line contains the lengths of those parts separated by the space. The last line of the file contains zero.

Output

The output should contains the smallest possible length of original sticks, one per line.

Sample Input

9
5 2 1 5 2 1 5 2 1
4
1 2 3 4
0

Sample Output

6
5

Source

Central Europe 1995
#include<iostream>
#include<queue>
#include<string.h>
using namespace std;
const int maxn=80;

char g[maxn][maxn];

bool vis[maxn][maxn];

int dis[maxn][maxn];

int go[4][2]={{-1,0},{1,0},{0,-1},{0,1}};

int x1,y1,x2,y2;

int w,h;

void bfs(int x,int y)
{
    queue <int> q;

    int tmp=x*(w+2)+y;

    q.push(tmp);

    vis[x][y]=true;

    while(!q.empty())
    {
        tmp=q.front();

        x=tmp/(w+2);

        y=tmp%(w+2);

       
        q.pop();

        if(x==x2 && y==y2) return;

        for(int i=0;i<4;i++)
        {
            int nx=x+go[i][0];
            int ny=y+go[i][1];

            while(nx>=0 && nx<=h+1 && ny>=0 && ny<=w+1 && !vis[nx][ny] && g[nx][ny]!=‘X‘)
            {
                tmp=nx*(w+2)+ny;
                vis[nx][ny]=true;
                dis[nx][ny]=dis[x][y]+1;
                q.push(tmp); 
                nx=nx+go[i][0];
                ny=ny+go[i][1];       
            }
                   
        }
    }
}

int main()
{
int i;


    int k=0;

    while(scanf("%d%d",&w,&h)!=EOF && (w||h))
    {
        memset(g,0,sizeof(g));

        for(i=1;i<=h;i++)
        {
            getchar();

            for(int j=1;j<=w;j++)
                scanf("%c",&g[i][j]);
        }
       
        printf("Board #%d:\n",++k);

        int t=0;

        while(scanf("%d%d%d%d",&y1,&x1,&y2,&x2) && (x1||y1||x2||y2))
        {
            memset(vis,false,sizeof(vis));

            memset(dis,0,sizeof(dis));

            g[x2][y2]=0;

            bfs(x1,y1); 

            if(dis[x2][y2]==0)
printf("Pair %d: impossible.\n",++t);
            else 
                printf("Pair %d: %d segments.\n",++t,dis[x2][y2]);

            g[x2][y2]=‘X‘;    //注意还原                                      
        } 

        printf("\n");                            
    }
    return 0;    
}

  

poj 1011

标签:des   blog   http   io   ar   os   sp   for   strong   

原文地址:http://www.cnblogs.com/a972290869/p/4101046.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!