码迷,mamicode.com
首页 > 其他好文 > 详细

hdu 1232

时间:2014-11-16 10:36:44      阅读:146      评论:0      收藏:0      [点我收藏+]

标签:des   blog   io   ar   os   sp   java   for   strong   

畅通工程

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 31869    Accepted Submission(s): 16795


Problem Description
某省调查城镇交通状况,得到现有城镇道路统计表,表中列出了每条道路直接连通的城镇。省政府“畅通工程”的目标是使全省任何两个城镇间都可以实现交通(但不一定有直接的道路相连,只要互相间接通过道路可达即可)。问最少还需要建设多少条道路? 
 

 

Input
测试输入包含若干测试用例。每个测试用例的第1行给出两个正整数,分别是城镇数目N ( < 1000 )和道路数目M;随后的M行对应M条道路,每行给出一对正整数,分别是该条道路直接连通的两个城镇的编号。为简单起见,城镇从1到N编号。 
注意:两个城市之间可以有多条道路相通,也就是说
3 3
1 2
1 2
2 1
这种输入也是合法的
当N为0时,输入结束,该用例不被处理。 
 

 

Output
对每个测试用例,在1行里输出最少还需要建设的道路数目。 
 

 

Sample Input
4 2 1 3 4 3 3 3 1 2 1 3 2 3 5 2 1 2 3 5 999 0 0
 

 

Sample Output
1 0 2 998
Hint
Hint
Huge input, scanf is recommended.
 

 

Source
#include<iostream>
#include<cstdio>
#include<cstring> 
#include<cstdlib>
#include<cmath>
#include<string>
#include<algorithm>
#include<queue>
#include<vector>
int set[1010],n,m,ans;
int find(int x)
{
return x==set[x]?x:set[x]=find(set[x]);
}
void Union(int x,int y)
{
int ux,uy;
ux=find(x),uy=find(y);
if(ux!=uy)
set[ux]=uy;
}
int main()
{
while(scanf("%d",&n),n)
{
ans=0;
scanf("%d",&m);
for(int i=1;i<=n;i++)
set[i]=i;
for(int i=1;i<=m;i++)
{
int x,y;
scanf("%d%d",&x,&y);
Union(x,y);
}
for(int i=1;i<=n;i++)
if(set[i]==i)
ans++;
printf("%d\n",ans-1);
}
return 0;
}

  

hdu 1232

标签:des   blog   io   ar   os   sp   java   for   strong   

原文地址:http://www.cnblogs.com/a972290869/p/4101074.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!