码迷,mamicode.com
首页 > 其他好文 > 详细

poj 3278

时间:2014-11-16 10:38:06      阅读:182      评论:0      收藏:0      [点我收藏+]

标签:des   blog   http   io   ar   os   sp   for   strong   

Catch That Cow
Time Limit: 2000MS   Memory Limit: 65536K
Total Submissions: 48376   Accepted: 15149

Description

Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.

* Walking: FJ can move from any point X to the points - 1 or + 1 in a single minute
* Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?

Input

Line 1: Two space-separated integers: N and K

Output

Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.

Sample Input

5 17

Sample Output

4

Hint

The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.

Source

USACO 2007 Open Silver
#include<iostream>
#include<cstdio>
#include<cstring>
#include<string>
#include<cstdlib>
#include<cmath>
#include<algorithm>
#include<queue>
using namespace std;
int dis[100001],check[100001],n,k,minn=100001;
queue<int> q;
void bfs()
{
 	q.push(n);
 	check[n]=1;
 	while(!q.empty())
 	{
    int x;
    x=q.front(),q.pop();
    if(x==k)
    minn=min(minn,dis[k]);
    if(x-1>=0&&x-1<=100000&&!check[x-1])
    q.push(x-1),dis[x-1]=dis[x]+1,check[x-1]=1;
    if(x+1>=0&&x+1<=100000&&!check[x+1])
    q.push(x+1),dis[x+1]=dis[x]+1,check[x+1]=1;
    if(x*2>=0&&x*2<=100000&&!check[x*2])
    q.push(x*2),dis[x*2]=dis[x]+1,check[x*2]=1;
}
}	    
int main()
{
 	memset(dis,0,sizeof(dis));
 	memset(check,0,sizeof(check));
 	scanf("%d%d",&n,&k);
 	bfs();
 	printf("%d\n",minn);
 	return 0;
}

  

poj 3278

标签:des   blog   http   io   ar   os   sp   for   strong   

原文地址:http://www.cnblogs.com/a972290869/p/4101051.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!