码迷,mamicode.com
首页 > 其他好文 > 详细

POJ 1979 Red and Black (深搜)

时间:2014-11-16 10:46:08      阅读:107      评论:0      收藏:0      [点我收藏+]

标签:poj   搜索   

Red and Black
Time Limit: 1000MS   Memory Limit: 30000K
Total Submissions: 23095   Accepted: 12467

Description

There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can‘t move on red tiles, he can move only on black tiles. 

Write a program to count the number of black tiles which he can reach by repeating the moves described above. 

Input

The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20. 

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows. 

‘.‘ - a black tile 
‘#‘ - a red tile 
‘@‘ - a man on a black tile(appears exactly once in a data set) 
The end of the input is indicated by a line consisting of two zeros. 

Output

For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).

Sample Input

6 9
....#.
.....#
......
......
......
......
......
#@...#
.#..#.
11 9
.#.........
.#.#######.
.#.#.....#.
.#.#.###.#.
.#.#..@#.#.
.#.#####.#.
.#.......#.
.#########.
...........
11 6
..#..#..#..
..#..#..#..
..#..#..###
..#..#..#@.
..#..#..#..
..#..#..#..
7 7
..#.#..
..#.#..
###.###
...@...
###.###
..#.#..
..#.#..
0 0

Sample Output

45
59
6
13

Source

简答的模板,
代码如下;
#include<stdio.h>
#include<string.h>
char a[22][22];
int v[22][22];
int sum;
void dfs(int i,int j)
{
	if(a[i-1][j]=='.'&&v[i-1][j]==0)
	{
		sum++;
		v[i-1][j]=1;
		dfs(i-1,j);
	}
	if(a[i][j-1]=='.'&&v[i][j-1]==0)
	{
		sum++;
		v[i][j-1]=1;
		dfs(i,j-1);
	}
	if(a[i][j+1]=='.'&&v[i][j+1]==0)
	{
		sum++;
		v[i][j+1]=1;
		dfs(i,j+1);
	}
	if(a[i+1][j]=='.'&&v[i+1][j]==0)
	{
		sum++;
		v[i+1][j]=1;
		dfs(i+1,j);
	}
}
int main()
{
	int n,m,i,j;
	while(~scanf("%d%d",&n,&m),n||m)
	{
		getchar();
		sum=0;
		memset(v,0,sizeof(v));
		memset(a,'#',sizeof(a));
		for(i=0;i<m;i++)
		{
			for(j=0;j<n;j++)
			{
				scanf("%c",&a[i][j]);
			}
			getchar();
		}
		for(i=0;i<m;i++)
		{
			for(j=0;j<n;j++)
			{
				if(a[i][j]=='@')
				{
					v[i][j]=1;
					sum+=1;
					dfs(i,j);
					break;
				}
			}
		}
		printf("%d\n",sum);
	}
	return 0;
}


POJ 1979 Red and Black (深搜)

标签:poj   搜索   

原文地址:http://blog.csdn.net/ice_alone/article/details/41159245

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!