码迷,mamicode.com
首页 > 其他好文 > 详细

hdu 1796

时间:2014-11-16 11:51:27      阅读:128      评论:0      收藏:0      [点我收藏+]

标签:des   blog   http   io   ar   os   sp   java   for   

How many integers can you find

Time Limit: 12000/5000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 4473    Accepted Submission(s): 1284


Problem Description
  Now you get a number N, and a M-integers set, you should find out how many integers which are small than N, that they can divided exactly by any integers in the set. For example, N=12, and M-integer set is {2,3}, so there is another set {2,3,4,6,8,9,10}, all the integers of the set can be divided exactly by 2 or 3. As a result, you just output the number 7.
 

 

Input
  There are a lot of cases. For each case, the first line contains two integers N and M. The follow line contains the M integers, and all of them are different from each other. 0<N<2^31,0<M<=10, and the M integer are non-negative and won’t exceed 20.
 

 

Output
  For each case, output the number.
 

 

Sample Input
12 2 2 3
 

 

Sample Output
7
 

 

Author
wangye
 

 

Source
 

 

Recommend
wangye
http://acm.hdu.edu.cn/showproblem.php?pid=1796
#include<iostream>
#include<cstdio>
#include<cmath>
#include<cstring>
#include<cstdlib>
#include<string>
#include<algorithm>
#include<queue>
#include<vector>
#include<set>
using namespace std;
#define  LL long long
LL n,m,a[20],ans;
LL gcd(LL a,LL b)
{
return b?gcd(b,a%b):a;
}
void dfs(LL id,LL flag,LL LCM)
{
LCM=a[id]*LCM/gcd(a[id],LCM);
if(flag)
ans=ans+n/LCM;
else
ans=ans-n/LCM;
for(LL i=id+1;i<=m;i++)
dfs(i,!flag,LCM);
}
int main()
{
while(scanf("%lld%lld",&n,&m)!=EOF)
{
ans=0;
for(int i=1;i<=m;i++)
{
scanf("%d",&a[i]);
if(!a[i])
i--,m--;
}
n--;
for(int i=1;i<=m;i++)
dfs(i,1,a[i]);
printf("%lld\n",ans);
}
return 0;
}

  

hdu 1796

标签:des   blog   http   io   ar   os   sp   java   for   

原文地址:http://www.cnblogs.com/a972290869/p/4101121.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!