码迷,mamicode.com
首页 > 其他好文 > 详细

poj 3264

时间:2014-11-16 11:55:25      阅读:173      评论:0      收藏:0      [点我收藏+]

标签:des   blog   http   io   ar   os   sp   for   strong   

Balanced Lineup
Time Limit: 5000MS   Memory Limit: 65536K
Total Submissions: 35938   Accepted: 16851
Case Time Limit: 2000MS

Description

For the daily milking, Farmer John‘s N cows (1 ≤ N ≤ 50,000) always line up in the same order. One day Farmer John decides to organize a game of Ultimate Frisbee with some of the cows. To keep things simple, he will take a contiguous range of cows from the milking lineup to play the game. However, for all the cows to have fun they should not differ too much in height.

Farmer John has made a list of Q (1 ≤ Q ≤ 200,000) potential groups of cows and their heights (1 ≤ height ≤ 1,000,000). For each group, he wants your help to determine the difference in height between the shortest and the tallest cow in the group.

Input

Line 1: Two space-separated integers, N and Q
Lines 2..N+1: Line i+1 contains a single integer that is the height of cow i 
Lines N+2..N+Q+1: Two integers A and B (1 ≤ A ≤ B ≤ N), representing the range of cows from A to B inclusive.

Output

Lines 1..Q: Each line contains a single integer that is a response to a reply and indicates the difference in height between the tallest and shortest cow in the range.

Sample Input

6 3
1
7
3
4
2
5
1 5
4 6
2 2

Sample Output

6
3
0

Source

USACO 2007 January Silver
#include<iostream>
#include<cstdio>
#include<cstring>
#include<cstdlib>
#include<string>
#include<queue>
#include<cmath>
#include<vector>
using namespace std;
const int maxn=100010;
int n,q;
int a[maxn],dpmax[maxn][20],dpmin[maxn][20];
int main()
{
    scanf("%d%d",&n,&q);
    for(int i=1;i<=n;i++)
    scanf("%d",&a[i]);
    for(int i=1;i<=n;i++)
    dpmax[i][0]=dpmin[i][0]=a[i];
    for(int j=1;j<20;j++)
        for(int i=1;i<n;i++)
        if(i+(1<<j)-1<=n)
        {
           dpmax[i][j]=max(dpmax[i][j-1],dpmax[i+(1<<(j-1))][j-1]);
           dpmin[i][j]=min(dpmin[i][j-1],dpmin[i+(1<<(j-1))][j-1]);
        }
    for(int i=1;i<=q;i++)
    {
        int m,n;
        scanf("%d%d",&m,&n);
        int k=(int)((log(n-m+1.0))/(log(2.0)));
        int maxi=max(dpmax[m][k],dpmax[n-(1<<k)+1][k]);
        int mini=min(dpmin[m][k],dpmin[n-(1<<k)+1][k]);
        printf("%d\n",maxi-mini);
    }
    return 0;
}
    

  

poj 3264

标签:des   blog   http   io   ar   os   sp   for   strong   

原文地址:http://www.cnblogs.com/a972290869/p/4101122.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!