码迷,mamicode.com
首页 > 其他好文 > 详细

状压DP [POJ 3311] Hie with the Pie

时间:2014-11-16 13:17:58      阅读:213      评论:0      收藏:0      [点我收藏+]

标签:des   style   blog   io   color   ar   os   sp   for   

Hie with the Pie
Time Limit: 2000MS   Memory Limit: 65536K
Total Submissions: 4712   Accepted: 2502

Description

The Pizazz Pizzeria prides itself in delivering pizzas to its customers as fast as possible. Unfortunately, due to cutbacks, they can afford to hire only one driver to do the deliveries. He will wait for 1 or more (up to 10) orders to be processed before he starts any deliveries. Needless to say, he would like to take the shortest route in delivering these goodies and returning to the pizzeria, even if it means passing the same location(s) or the pizzeria more than once on the way. He has commissioned you to write a program to help him.

Input

Input will consist of multiple test cases. The first line will contain a single integer n indicating the number of orders to deliver, where 1 ≤ n ≤ 10. After this will be n + 1 lines each containing n + 1 integers indicating the times to travel between the pizzeria (numbered 0) and the n locations (numbers 1 to n). The jth value on the ith line indicates the time to go directly from location i to location j without visiting any other locations along the way. Note that there may be quicker ways to go from i to j via other locations, due to different speed limits, traffic lights, etc. Also, the time values may not be symmetric, i.e., the time to go directly from location i to j may not be the same as the time to go directly from location j to i. An input value of n = 0 will terminate input.

Output

For each test case, you should output a single number indicating the minimum time to deliver all of the pizzas and return to the pizzeria.

Sample Input

3
0 1 10 10
1 0 1 2
10 1 0 10
10 2 10 0
0

Sample Output

8
#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
#define INF 0x7ffffff

int n;
int mpt[12][12];
int dp[12][1<<12];                               //dp[i][j]表示第i个点状态为j时的最小值

void floyd()
{
    for(int k=0;k<=n;k++)
    {
        for(int i=0;i<=n;i++)
        {
            for(int j=0;j<=n;j++)
            {
                mpt[i][j]=min(mpt[i][j],mpt[i][k]+mpt[k][j]);
            }
        }
    }
}

int main()
{
    int i,j,k;
    while(scanf("%d",&n),n)
    {
        for(i=0;i<=n;i++)
        {
            for(j=0;j<=n;j++)
            {
                scanf("%d",&mpt[i][j]);
                
            }
        }
        int MAX=1<<(n+1);
        for(i=0;i<=n;i++)
        {
            for(j=0;j<MAX;j++)
            {
                dp[i][j]=INF;
            }
        }

        floyd();
        for(i=0;i<=n;i++)
        {
            dp[i][1<<i]=mpt[0][i];
} for(i=0;i<MAX;i++)
{ for(j=0;j<=n;j++)
{ for(k=0;k<=n;k++)
{ if(i&(1<<k)==0) continue;
dp[j][i]=min(dp[j][i],dp[k][i&(~(1<<j))]+mpt[k][j]);
} } } printf("%d\n",dp[0][MAX-1]);
} return 0; }

 

状压DP [POJ 3311] Hie with the Pie

标签:des   style   blog   io   color   ar   os   sp   for   

原文地址:http://www.cnblogs.com/hate13/p/4101290.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!