码迷,mamicode.com
首页 > 其他好文 > 详细

HDU 4371 Alice and Bob

时间:2014-11-16 17:28:37      阅读:183      评论:0      收藏:0      [点我收藏+]

标签:des   style   io   color   ar   os   sp   java   for   

Alice and Bob

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 691    Accepted Submission(s): 420


Problem Description
Alice and Bob are interested in playing games. One day, they invent a game which has rules below:
1. Firstly, Alice and Bob choose some random positive integers, and here we describe them as n, d1, d2,..., dm.
2. Then they begin to write numbers alternately. At the first step, Alice has to write a “0”, here we let s1 = 0 ; Then, at the second step, Bob has to write a number s2which satisfies the condition that s2 = s1 + dk and s2 <= n, 1<= k <= m ; From the third step, the person who has to write a number in this step must write a number siwhich satisfies the condition that si = si-1 + dk or si = si-1 - dk , and si-2 < si <= n, 1 <= k <= m, i >= 3 at the same time.
3. The person who can’t write a legal number at his own step firstly lose the game.
Here’s the question, please tell me who will win the game if both Alice and Bob play the game optimally.
 

Input
At the beginning, an integer T indicating the total number of test cases.
Every test case begins with two integers n and m, which are described before. And on the next line are m positive integers d1, d2,..., dm.
T <= 100;
1 <= n <= 106;
1 <= m <= 100;
1 <= dk <= 106, 1 <= k <= m.
 

Output
For every test case, print “Case #k: ” firstly, where k indicates the index of the test case and begins from 1. Then if Alice will win the game, print “Alice”, otherwise “Bob”.
 

Sample Input
2 7 1 3 7 2 2 6
 

Sample Output
Case #1: Alice Case #2: Bob
 

两个人轮流写数字,写不出来的那个人就算输了。
因为要是数列处于间隔上升趋势,那么只要每次都选择最小的数字,不给对手做减法的余地



#include <iostream>
#include <stdio.h>
#include <cstring>
#include <string>
#include <algorithm>
#include <cmath>
#define N 1000009
using namespace std;

int a[N];
int n,m;
int t;

int main()
{
    while(~scanf("%d",&t))
    {
        for(int ca=1;ca<=t;ca++)
        {
        scanf("%d%d",&n,&m);
        for(int i=1;i<=m;i++)
        scanf("%d",&a[i]);

        sort(a+1,a+1+m);

        int s=0;
        int num=1;
        while(1)
        {
            num++;
            if(s+a[1]>n)
            {
                break;
            }
            s+=a[1];
        }

        printf("Case #%d: ",ca);
        if(num%2==0)
        cout<<"Alice"<<endl;
        else
        cout<<"Bob"<<endl;
        }

    }
    return 0;
}



HDU 4371 Alice and Bob

标签:des   style   io   color   ar   os   sp   java   for   

原文地址:http://blog.csdn.net/wust_zjx/article/details/41172245

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!