码迷,mamicode.com
首页 > 其他好文 > 详细

HDU 1069 LIS

时间:2014-11-17 21:23:43      阅读:159      评论:0      收藏:0      [点我收藏+]

标签:dp   贪心   

类似于dp的思想

Monkey and Banana

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 7926    Accepted Submission(s): 4091


Problem Description
A group of researchers are designing an experiment to test the IQ of a monkey. They will hang a banana at the roof of a building, and at the mean time, provide the monkey with some blocks. If the monkey is clever enough, it shall be able to reach the banana by placing one block on the top another to build a tower and climb up to get its favorite food.

The researchers have n types of blocks, and an unlimited supply of blocks of each type. Each type-i block was a rectangular solid with linear dimensions (xi, yi, zi). A block could be reoriented so that any two of its three dimensions determined the dimensions of the base and the other dimension was the height.

They want to make sure that the tallest tower possible by stacking blocks can reach the roof. The problem is that, in building a tower, one block could only be placed on top of another block as long as the two base dimensions of the upper block were both strictly smaller than the corresponding base dimensions of the lower block because there has to be some space for the monkey to step on. This meant, for example, that blocks oriented to have equal-sized bases couldn‘t be stacked.

Your job is to write a program that determines the height of the tallest tower the monkey can build with a given set of blocks.
 

Input
The input file will contain one or more test cases. The first line of each test case contains an integer n,
representing the number of different blocks in the following data set. The maximum value for n is 30.
Each of the next n lines contains three integers representing the values xi, yi and zi.
Input is terminated by a value of zero (0) for n.
 

Output
For each test case, print one line containing the case number (they are numbered sequentially starting from 1) and the height of the tallest possible tower in the format "Case case: maximum height = height".
 

Sample Input
1 10 20 30 2 6 8 10 5 5 5 7 1 1 1 2 2 2 3 3 3 4 4 4 5 5 5 6 6 6 7 7 7 5 31 41 59 26 53 58 97 93 23 84 62 64 33 83 27 0
 

Sample Output
Case 1: maximum height = 40 Case 2: maximum height = 21 Case 3: maximum height = 28 Case 4: maximum height = 342
 

Source
 
#include <stdio.h>
#include <stdlib.h>
#include <malloc.h>
#include <limits.h>
#include <ctype.h>
#include <string.h>
#include <string>
#include <math.h>
#include <algorithm>
#include <iostream>
#include <stack>
#include <deque>
#include <vector>
#include <set>
#include <map>
using namespace std;
#define MAXN 200 + 10

struct node{
    int x,y,z;
}a[MAXN];
int dp[MAXN];

bool cmp(node a,node b){
    if(a.x == b.x){
        return a.y < b.y;
    }
    return a.x < b.x;
}

int main(){
    int n,i,con,aa,bb,cc,j;
    int cas = 1;

    while(cin>>n){
        if(n == 0){
            break;
        }
        memset(dp,0,sizeof(dp));
       for(i=0;i<n;i++){
            scanf("%d%d%d",&aa,&bb,&cc);
            a[i*6].x=aa,a[i*6].y=bb,a[i*6].z=cc;
            a[i*6+1].x=aa,a[i*6+1].y=cc,a[i*6+1].z=bb;
            a[i*6+2].x=bb,a[i*6+2].y=aa,a[i*6+2].z=cc;
            a[i*6+3].x=bb,a[i*6+3].y=cc,a[i*6+3].z=aa;
            a[i*6+4].x=cc,a[i*6+4].y=aa,a[i*6+4].z=bb;
            a[i*6+5].x=cc,a[i*6+5].y=bb,a[i*6+5].z=aa;
       }
        sort(a,a+n*6,cmp);//按照长宽从小到大的顺序排
        int ans=0;
        int tmp;
        for(i=0;i<6*n;i++){
            tmp = 0;
            for(j=0;j<i;j++){
                if(a[i].x>a[j].x && a[i].y>a[j].y){
                    tmp = max(tmp,a[j].z);
                }
            }
            a[i].z+=tmp;
            ans = max(ans,a[i].z);
        }
        printf("Case %d: maximum height = %d\n",cas,ans);
        cas++;
    }

    return 0;
}


HDU 1069 LIS

标签:dp   贪心   

原文地址:http://blog.csdn.net/zcr_7/article/details/41214637

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!