码迷,mamicode.com
首页 > 其他好文 > 详细

hdu3006——The Number of set

时间:2014-11-17 22:55:55      阅读:320      评论:0      收藏:0      [点我收藏+]

标签:dfs

The Number of set

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1160    Accepted Submission(s): 709


Problem Description
Given you n sets.All positive integers in sets are not less than 1 and not greater than m.If use these sets to combinate the new set,how many different new set you can get.The given sets can not be broken.
 

Input
There are several cases.For each case,the first line contains two positive integer n and m(1<=n<=100,1<=m<=14).Then the following n lines describe the n sets.These lines each contains k+1 positive integer,the first which is k,then k integers are given. The input is end by EOF.
 

Output
For each case,the output contain only one integer,the number of the different sets you get.
 

Sample Input
4 4 1 1 1 2 1 3 1 4 2 4 3 1 2 3 4 1 2 3 4
 

Sample Output
15 2
 

Source
 

Recommend
gaojie   |   We have carefully selected several similar problems for you:  3007 3003 3004 3002 3005

同学让我看的这道题,刚看还以为是dp,后来仔细看了结果发现自己想不出如何简洁地表示状态,然后换了思路

我们可以发现,m <=14,这个条件给我很大的启发,为什么我不把一个集合看成一个整数A呢?集合里出现某个数我就在A的对应位上置1,然后,合并集合的操作就是或运算了,这时候只要加上标记然后dfs就可以得到答案了,数据比较小

#include <map>
#include <set>
#include <list>
#include <queue>
#include <stack>
#include <vector>
#include <cmath>
#include <cstdio>
#include <cstring>
#include <iostream>
#include <algorithm>

using namespace std;

int jihe[2222];
bool vis[33333];
int ans, n;

void dfs(int x, int v)
{
	for (int i = 1; i <= n; ++i)
	{
		if (vis[v | jihe[i]] || i == x)
		{
			continue;
		}
		vis[v | jihe[i]] = 1;
		ans++;
		dfs(i, v | jihe[i]);
	}
}

int main()
{
	int m, k, pos;
	while (~scanf("%d%d", &n, &m))
	{
		memset (vis, 0, sizeof(vis));
		memset (jihe, 0, sizeof(jihe));
		ans = 0;
		for (int i = 1; i <= n; ++i)
		{
			scanf("%d", &k);
			for (int j = 0; j < k; ++j)
			{
				scanf("%d", &pos);
				jihe[i] |= (1 << pos);
			}
			if (vis[jihe[i]])
			{
				continue;
			}
			vis[jihe[i]] = 1;
			ans++;
		}
		for (int i = 1; i <= n; ++i)
		{
			dfs(i, jihe[i]);
		}
		printf("%d\n", ans);
	}
	return 0;
}


 

hdu3006——The Number of set

标签:dfs

原文地址:http://blog.csdn.net/guard_mine/article/details/41217069

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!