码迷,mamicode.com
首页 > 其他好文 > 详细

zoj 3469 Food Delivery(区间dp)

时间:2014-11-17 22:57:23      阅读:529      评论:0      收藏:0      [点我收藏+]

标签:zoj3469   food delivery   区间dp   

Food Delivery

Time Limit: 2 Seconds      Memory Limit: 65536 KB

When we are focusing on solving problems, we usually prefer to stay in front of computers rather than go out for lunch. At this time, we may call for food delivery.

Suppose there are N people living in a straight street that is just lies on an X-coordinate axis. The ith person‘s coordinate is Xi meters. And in the street there is a take-out restaurant which has coordinates X meters. One day at lunchtime, each person takes an order from the restaurant at the same time. As a worker in the restaurant, you need to start from the restaurant, send food to the N people, and then come back to the restaurant. Your speed is V-1 meters per minute.

You know that the N people have different personal characters; therefore they have different feeling on the time their food arrives. Their feelings are measured by Displeasure Index. At the beginning, the Displeasure Index for each person is 0. When waiting for the food, the ithperson will gain Bi Displeasure Index per minute.

If one‘s Displeasure Index goes too high, he will not buy your food any more. So you need to keep the sum of all people‘s Displeasure Indexas low as possible in order to maximize your income. Your task is to find the minimal sum of Displeasure Index.

Input

The input contains multiple test cases, separated with a blank line. Each case is started with three integers N ( 1 <= N <= 1000 ), V ( V > 0),X ( X >= 0 ), then N lines followed. Each line contains two integers Xi ( Xi >= 0 ), Bi ( Bi >= 0), which are described above.

You can safely assume that all numbers in the input and output will be less than 231 - 1.

Please process to the end-of-file.

Output

For each test case please output a single number, which is the minimal sum of Displeasure Index. One test case per line.

Sample Input

5 1 0
1 1
2 2
3 3
4 4
5 5

Sample Output

55


题意:

送餐员送餐问题。有n个人叫餐,每个人都在x轴上,并且每个人都有个坑爹度(和等餐时间有关,据说顾客认为坑爹值到一定程度他的小宇宙就要爆发).现在送餐员从x轴上的某点出发,路上奔跑速度是v,要一次性把所有餐送完。叫餐的人得到餐的时间和顺序不同,坑爹度总和也就不同。合格的送餐员要让客户体验最好,请问最少坑爹度和为多少。


题解:

从餐厅为x的位置作为dp的起始点,dp[i][j][k]表示[i,j]这段送完后愤怒值的最优解,k=0表示停在左边i处,k=1停在右边j处。

dp[i][j][0] = min ( dp[i][j][0], dp[i + 1][j][1] + ( sum[i] + sum[n] - sum[j] ) * ( a[j].x - a[i].x ) );
    dp[i][j][0] = min ( dp[i][j][0], dp[i + 1][j][0] + ( sum[i] + sum[n] - sum[j] ) * ( a[i + 1].x - a[i].x ) );
    dp[i][j][1] = min ( dp[i][j][1], dp[i][j - 1][0] + ( sum[i - 1] + sum[n] - sum[j - 1] ) * ( a[j].x - a[i].x ) );
    p[i][j][1] = min ( dp[i][j][1], dp[i][j - 1][1] + ( sum[i - 1] + sum[n] - sum[j - 1] ) * ( a[j].x - a[j - 1].x ) )


#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<string>
#include<algorithm>
#include<cstdlib>
#include<set>
#include<queue>
#include<stack>
#include<vector>
#include<map>

#define N 100010
#define Mod 10000007
#define lson l,mid,idx<<1
#define rson mid+1,r,idx<<1|1
#define lc idx<<1
#define rc idx<<1|1
const double EPS = 1e-11;
const double PI = acos ( -1.0 );
const double E = 2.718281828;

typedef long long ll;

const int INF = 0x3f3f3f3f;

using namespace std;

struct node
{
    int x, di;
} a[1010];

int n, v, x;
int sum[1010], dp[1010][1010][2];

bool cmp ( node a, node b )
{
    return a.x < b.x;
}

int main()
{
    while ( cin >> n >> v >> x )
    {
        for ( int i = 1; i <= n; i++ )
        {
            scanf ( "%d%d", &a[i].x, &a[i].di );
        }
        ///把x赋给a[n++],防止在n个地址中找不到x
        n++;
        a[n].x = x;
        a[n].di = 0;
        sort ( a + 1, a + n + 1, cmp );
        sum[0] = 0;
        for ( int i = 1; i <= n; i++ )
            sum[i] = sum[i - 1] + a[i].di;///前缀和
        int res;
        for ( int i = 1; i <= n; i++ )///找到dp的起始点
            if ( a[i].x == x )
            {
                res = i;
                break;
            }
        for ( int i = 1; i <= n; i++ )
            for ( int j = 1; j <= n; j++ )
                dp[i][j][0] = dp[i][j][1] = INF;
        dp[res][res][0] = dp[res][res][1] = 0;
        for ( int i = res; i >= 1; i-- )
        {
            for ( int j = res; j <= n; j++ )
            {
                if ( i == j )
                    continue;
                    ///停在左边
                dp[i][j][0] = min ( dp[i][j][0], dp[i + 1][j][1] + ( sum[i] + sum[n] - sum[j] ) * ( a[j].x - a[i].x ) );
                
                dp[i][j][0] = min ( dp[i][j][0], dp[i + 1][j][0] + ( sum[i] + sum[n] - sum[j] ) * ( a[i + 1].x - a[i].x ) );
                
                ///右边
                dp[i][j][1] = min ( dp[i][j][1], dp[i][j - 1][0] + ( sum[i - 1] + sum[n] - sum[j - 1] ) * ( a[j].x - a[i].x ) );
                
                dp[i][j][1] = min ( dp[i][j][1], dp[i][j - 1][1] + ( sum[i - 1] + sum[n] - sum[j - 1] ) * ( a[j].x - a[j - 1].x ) );
            }
        }
        cout << min ( dp[1][n][1], dp[1][n][0] ) *v << endl;
    }
    return 0;
}



zoj 3469 Food Delivery(区间dp)

标签:zoj3469   food delivery   区间dp   

原文地址:http://blog.csdn.net/acm_baihuzi/article/details/41216983

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!